Bug 1124817

Summary: It is possible to start multiple VM snapshot delete operations
Product: [Fedora] Fedora Reporter: Martin Kolman <mkolman>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 21CC: berrange, crobinso, mkolman, virt-maint, vpodzime
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-20 23:40:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin Kolman 2014-07-30 11:52:03 UTC
Description of problem:
It is possible to start a delete operation for single snapshot multiple times.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create/have at least one VM snapshot
2. try to delete the snapshot
3. repeat 2

Actual results:
It is possible to start multiple snapshot delete operations and eventually Virt Manager will return this traceback:

Error deleting snapshot 'pre post F21 mas rebuild update': Domain snapshot not found: no domain snapshot with matching name 'pre post F21 mas rebuild update'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 91, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 127, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 183, in delete
    self._backend.delete()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4702, in delete
    if ret == -1: raise libvirtError ('virDomainSnapshotDelete() failed')
libvirtError: Domain snapshot not found: no domain snapshot with matching name 'pre post F21 mas rebuild update'

Also the snapshot appears to be gone.

Expected results:
It is not possible to start multiple delete operations for a single VM snapshot.

Comment 1 Martin Kolman 2014-07-30 11:54:19 UTC
Looks like the traceback appears multiple times, based on how many delete operations you managed to start.

Comment 2 Cole Robinson 2014-09-20 23:40:48 UTC
I think this was fixed by this commit, which is also in F21. Since it's a minor feature request, just closing as CURRENTRELEASE for f21


commit f5b29c0416be5d05f2d684070d84c7600601907c
Author: Giuseppe Scrivano <gscrivan@redhat.com>
Date:   Thu Jul 31 14:28:54 2014 +0200

    snapshots: allow deleting multiple snapshots
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1124818
    
    Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>