Bug 1125031

Summary: The default admin.conf and consumer.conf had quotes around their ca_path default settings
Product: [Retired] Pulp Reporter: Randy Barlow <rbarlow>
Component: user-experienceAssignee: Randy Barlow <rbarlow>
Status: CLOSED CURRENTRELEASE QA Contact: Preethi Thomas <pthomas>
Severity: high Docs Contact:
Priority: medium    
Version: MasterCC: pthomas
Target Milestone: ---Keywords: Triaged
Target Release: 2.4.0   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-09 06:55:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Randy Barlow 2014-07-30 22:37:34 UTC
It is important not to put quotes around these settings because that causes the path used to have quotes, which isn't a valid path on most Unix systems ☺

Comment 1 Randy Barlow 2014-07-30 22:38:10 UTC
https://github.com/pulp/pulp/pull/1072

Comment 2 Preethi Thomas 2014-08-06 13:51:05 UTC
verified
[root@cloud-qe-15 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.30.beta.el6.noarch
[root@cloud-qe-15 ~]# 

# certificates (with openssl-style hashed symlinks, one certificate per file).
ca_path = /etc/pki/tls/certs/ca-bundle.crt



[root@cloud-qe-15 ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

[root@cloud-qe-15 ~]#

Comment 3 Randy Barlow 2014-08-09 06:55:38 UTC
This has been fixed in Pulp 2.4.0-1.