Bug 1125193

Summary: Evolution syncro error between Google calendar and Fedora online account
Product: [Fedora] Fedora Reporter: GregVD <gregvd77>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: fabiano, lucilanga, mariaengstrom1971, mbarnes, mcrha, stephan, tpopela
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: evolution-data-server-3.12.4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-31 14:44:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description GregVD 2014-07-31 09:37:55 UTC
Google account configured in Fedora Online Account, doesnt works/syncro with google calendar. Other services like mail, documents, works fine. When you open Evolution, or Fedora tries to syncro your calendar, a window popup requesting your password appears on the screen. 


Version-Release number of selected component (if applicable): Fedora 20 kernel 3.15.6-200 and Evolution 3.10.4. Gnome 3.10.2


How reproducible:
That password request popup screen appears when you login in Gnome Fedora 20 and syncro your calendar with your Google account. By the way, opening Evolution (see your calendar).


Actual results:
A windows popup appears requesting our gmail account password.

Expected results:
Syncro the google calendar in Fedora/Evolution service.

Additional info:

Comment 1 mariaengstrom1971 2014-07-31 10:07:10 UTC
I have exactly same problem, same versions also, problem started after I did an update.

Comment 2 Stephan Gross 2014-07-31 12:27:29 UTC
I also have the same problem, with the same Fedora 20 kernel version, Evolution version, and Gnome version.

Comment 3 Milan Crha 2014-07-31 14:44:02 UTC
Thanks for a bug report. The problem is that the evolution-data-server 3.10.x doesn't support OAuth authentication against the Google server for CalDAV calendars, thus the token received by GNOME Online Accounts doesn't work, which results in the password prompt. The OAuth token support for CalDAV was added in time of 3.12.x development, thus this will be fixed in Fedora 21, which has 3.12.x evolution packages.