Bug 1125215

Summary: Fail to install dependency for zend app
Product: OpenShift Online Reporter: Yan Du <yadu>
Component: ImageAssignee: Vojtech Vitek <vvitek>
Status: CLOSED CURRENTRELEASE QA Contact: libra bugs <libra-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.xCC: hripps, jokerman, mmccomas
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-10 00:50:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yan Du 2014-07-31 10:44:48 UTC
Description of problem:

remote: Not stopping cartridge zend because hot deploy is enabled
remote: Not stopping cartridge mysql because hot deploy is enabled
remote: Building git ref 'master', commit 69bf15b
remote: Checking pear: QA_Peardoc_Coverage
remote: 
remote: Could not open input file: /var/lib/openshift/53da52964b6c8378b80009b2/zend/php-5.4/share/pear/pearcmd.php
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/53da52964b6c8378b80009b2/zend
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://53da52964b6c8378b80009b2@zend-a.dev.rhcloud.com/~/git/zend.git/
   391b9d1..69bf15b  master -> master




remote: Not stopping cartridge zend because hot deploy is enabled
remote: Building git ref 'master', commit 646e338
remote: Checking pear: channel://pear.php.net/Validate-0.8.4
remote: 
remote: Could not open input file: /var/lib/openshift/53da555bffcd7768fe0008dd/zend/php-5.4/share/pear/pearcmd.php
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/53da555bffcd7768fe0008dd/zend
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://53da555bffcd7768fe0008dd@z-a.dev.rhcloud.com/~/git/z.git/
   e9d8813..646e338  master -> master



Version-Release number of selected component (if applicable):
devenv_stage_937



How reproducible:
always



Steps to Reproduce:

1. rhc app create zend zend-6.1 mysql-5.1
2. Add a dependency 
 eg : echo 'QA_Peardoc_Coverage' >> deplist.txt
  or echo channel://pear.php.net/Validate-0.8.4 > deplist.txt 
3. git push



Actual results:
fail to install dependency



Expected results:
could install normally

Comment 1 Vojtech Vitek 2014-08-01 16:27:57 UTC
https://github.com/openshift/li/pull/2774
https://github.com/openshift/li/pull/2775

Note for QE:
If you don't have any backups of your INT/STG apps and you already proceeded with the previous migration, you might want to restore the PEARs with the following command:
> mv ${OPENSHIFT_ZEND_DIR}php-5.4/share/pear{-to-be-removed,}

Comment 2 Yan Du 2014-08-04 06:14:01 UTC
Test on STG(devenv-stage_946). issue have been fixed.

remote: Not stopping cartridge zend because hot deploy is enabled
remote: Building git ref 'master', commit 6f67cc8
remote: Checking pear: channel://pear.php.net/Validate-0.8.4
remote: 
remote: Failed to download pear/Net_IDNA within preferred state "stable", latest release is version 0.8.1, stability "beta", use "channel://pear.php.net/Net_IDNA-0.8.1" to install
remote: pear/Validate can optionally use package "pear/Net_IDNA" (version >= 0.7.1)
remote: downloading Validate-0.8.4.tgz ...
remote: Starting to download Validate-0.8.4.tgz (20,809 bytes)
remote: ........done: 20,809 bytes
remote: downloading Date-1.4.7.tgz ...
remote: Starting to download Date-1.4.7.tgz (55,754 bytes)
remote: ...done: 55,754 bytes
remote: install ok: channel://pear.php.net/Validate-0.8.4
remote: install ok: channel://pear.php.net/Date-1.4.7
remote: Preparing build for deployment
remote: Deployment id is addf293c
remote: Activating deployment
remote: Not starting cartridge zend because hot deploy is enabled
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://53df1e2ddbd93cf3590000de@zend-a.stg.rhcloud.com/~/git/zend.git/

Move to verified.