Bug 1125258

Summary: union _LITTLE_ENDIAN not correct
Product: [Fedora] Fedora Reporter: Menanteau Guy <menantea>
Component: vnc-reflectorAssignee: Petr Pisar <ppisar>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: ppisar
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
URL: https://sourceforge.net/p/vnc-reflector/bugs/8/
Whiteboard:
Fixed In Version: vnc-reflector-1.2.4-17.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-01 13:58:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1051573    
Attachments:
Description Flags
patch to fix union _LITTLE_ENDIAN none

Description Menanteau Guy 2014-07-31 12:48:02 UTC
Created attachment 922907 [details]
patch to fix union _LITTLE_ENDIAN

vnc-reflector build failed because of invalid declaration:
union _LITTLE_ENDIAN { ... } ...;

http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/4455/1944455/build.log

vnc-reflector-1.2.4-16
gcc-4.9.0-14

Please consider this patch.

Comment 1 Petr Pisar 2014-08-01 12:24:06 UTC
Is that really invalid syntax? My C11 draft does not think so. It looks like the symbol _LITTLE_ENDIAN is defined on your platform to an integer literal. However GCC is not the source <https://gcc.gnu.org/onlinedocs/cpp/Common-Predefined-Macros.html>. Isn't it bug in some of the included header file?

I understand the identifier starting with underscore is really unfortunate and I can remove it as it's nowhere used. I just think that the real problem is somewhere else.

Comment 2 Petr Pisar 2014-08-01 13:58:37 UTC
Fixed as vnc-reflector-1.2.4-17.fc21 in F21.