Bug 1126063

Summary: import config-file needs to accept puppet-interview-answers from a config-file
Product: Red Hat Satellite 6 Reporter: Grant Gainey <ggainey>
Component: TransitionsAssignee: Grant Gainey <ggainey>
Status: CLOSED CURRENTRELEASE QA Contact: Lukas Pramuk <lpramuk>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, cperry, cwelton, ggainey, jmontleo, mkollar, sthirugn, tkolhar
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-11 12:29:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1125243    

Description Grant Gainey 2014-08-01 18:01:43 UTC
Currently import config-file answers the 'puppet module generate' interview-questions with hardcoded strings.

The interview is:

===
~ $ puppet module generate foo-bar
We need to create a metadata.json file for this module.  Please answer the
following questions; if the question is not applicable to this module, feel free
to leave it blank.

Puppet uses Semantic Versioning (semver.org) to version modules.
What version is this module?  [0.1.0]

Who wrote this module?  [foo]

What license does this module code fall under?  [Apache 2.0]

How would you describe this module in a single sentence?

Where is this module's source code repository?

Where can others go to learn more about this module?

Where can others go to file issues about this module?
===

'version', 'author', 'license', 'descr', 'srcrepo', 'learnmore', 'fileissues'

Default (shipped) values should be

1.0.0, 'hammer import config-file --csv-file=path-to-export.csv', 'Module created from soeorg-soeconfig_rhel5_dev', '', '', ''

The user is going to need to decide what the srcrepo/learnmore/fileissues URLs are supposed to be.

config-file ships as /etc/hammer/cli.import.d/puppet_interview_answers.yml, command takes --answers-file= param if you want to point at your own.

Comment 1 RHEL Product and Program Management 2014-08-01 18:03:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-08-01 19:18:49 UTC
commit a34240180b41572dde50175aa1d2ac2484489c98

Comment 5 Tazim Kolhar 2014-09-03 07:27:45 UTC
FAILEDQA:

config-file did not ship as /etc/hammer/cli.import.d/puppet_interview_answers.yml

# cd /etc/hammer/cli.import.d
-bash: cd: /etc/hammer/cli.import.d: No such file or directory

Comment 6 Tazim Kolhar 2014-09-03 09:06:00 UTC
shifting this BZ to ON_QA as mentioned in the email
sorry

Comment 7 Matej Kollar 2014-09-05 13:35:16 UTC
Config file was to be relocated to
/etc/hammer/cli.modules.d/import/interview_answers.yml

Comment 9 Matej Kollar 2014-09-05 14:09:45 UTC
verified with rubygem-hammer_cli_import-0.10.4-1

Comment 10 Bryan Kearney 2014-09-11 12:29:47 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.