Bug 1126198

Summary: [Cloud Init] Adding new network with Cloud Init shouldn't provide any value for new network interface
Product: [Retired] oVirt Reporter: GenadiC <gcheresh>
Component: ovirt-engine-webadminAssignee: Shahar Havivi <shavivi>
Status: CLOSED CURRENTRELEASE QA Contact: Michael Burman <mburman>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.5CC: bugs, ecohen, gklein, istein, mgoldboi, michal.skrivanek, rbalakri, yeylon
Target Milestone: ---   
Target Release: 3.6.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: virt
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-04 11:28:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description GenadiC 2014-08-03 12:46:36 UTC
Description of problem:
When adding a new network in cloud Init, you need to enter a name of network interface. The following string appears when you do it: "ethX [Click to Change]"
So you need to remove the whole string and replace it with the interface you want.
Instead of it the empty line should be provided so I can insert the value I want


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit VM and try to add network through Cloud Init
2.
3.

Actual results:
"ethX [Click to Change]" appears for a network interface

Expected results:
Empty line should appear instead

Additional info:

Comment 1 Omer Frenkel 2014-08-04 08:24:07 UTC
maybe this should be a tool tip

Comment 2 Michael Burman 2015-04-22 06:48:07 UTC
Verified on - 3.6.0-0.0.master.20150412172306.git55ba764.el6

Comment 3 Sandro Bonazzola 2015-11-04 11:28:57 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.