Bug 1126314

Summary: Lockdown can't be enabled through the firewall-cmd
Product: [Fedora] Fedora Reporter: Jakub Jelen <jjelen>
Component: firewalldAssignee: Thomas Woerner <twoerner>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jpopelka, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-04 08:56:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1017034    

Description Jakub Jelen 2014-08-04 07:34:06 UTC
Description of problem:
When trying to enable lockdown through firewall-cmd, I receive strange errors:

# firewall-cmd --lockdown-on
Error: yes is <type 'str'>, expected <type 'dict'>

# firewall-cmd --lockdown-off
Error: no is <type 'str'>, expected <type 'dict'>

This is caused by commit 7b8d76273939d28b96b6a3e0bb99b2c6a8e6e1c3 - strict type checking.

When I try to enable/disable lockdown directly through d-bus, it works fine.

Version-Release number of selected component (if applicable):
git upstream

How reproducible:
deterministic