Bug 1126618

Summary: import-config-file needs an upload switch
Product: Red Hat Satellite 6 Reporter: Grant Gainey <ggainey>
Component: TransitionsAssignee: Grant Gainey <ggainey>
Status: CLOSED CURRENTRELEASE QA Contact: Lukas Pramuk <lpramuk>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, cperry, cwelton, ggainey, jmontleo, mkollar
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-11 12:26:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1125243    

Description Grant Gainey 2014-08-04 21:39:24 UTC
Currently import config-file always builds and uploads the puppet-modules. Need to let that be under user-control with a switch - if --dont-upload is set, create the module-directory-structure, but do not puppet-module-build or upload.

Comment 1 RHEL Product and Program Management 2014-08-04 21:43:45 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-08-05 15:03:01 UTC
commit 5fe2e4d6037d2a803757c49b5da64c84b87f582b

Comment 4 Grant Gainey 2014-08-06 16:33:06 UTC
commit b96d64aa363d04237c81af24e85c324de2407777 as well

Comment 7 Matej Kollar 2014-09-03 15:21:29 UTC
verified with rubygem-hammer_cli_import-0.10.4-1

Comment 8 Bryan Kearney 2014-09-11 12:26:50 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.