Bug 1126629

Summary: Unresolve dependency for katello CDN
Product: Red Hat Satellite 6 Reporter: Brett Thurber <bthurber>
Component: PackagingAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED NOTABUG QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.0CC: bbuckingham, bkearney, bthurber
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-28 13:09:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brett Thurber 2014-08-04 22:11:57 UTC
Description of problem:
Once subscribed to the proper channels, execute yum install katello.  Receive the following dependency failure:
--> Finished Dependency Resolution
Error: Package: PyYAML-3.09-3.el6sat.x86_64 (@red-hat-satellite)
           Requires: libyaml-0.so.1()(64bit)
           Removing: libyaml-0.1.2-5.el6.x86_64 (@red-hat-satellite)
               libyaml-0.so.1()(64bit)
           Updated By: libyaml-0.1.3-1.4.el6.x86_64 (rhel-server-rhscl-6-rpms)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
6.0 HTB

How reproducible:
Every time.

Steps to Reproduce:
1. Register system to required channels.
2. Execute yum install katello 

Actual results:
--> Finished Dependency Resolution
Error: Package: PyYAML-3.09-3.el6sat.x86_64 (@red-hat-satellite)
           Requires: libyaml-0.so.1()(64bit)
           Removing: libyaml-0.1.2-5.el6.x86_64 (@red-hat-satellite)
               libyaml-0.so.1()(64bit)
           Updated By: libyaml-0.1.3-1.4.el6.x86_64 (rhel-server-rhscl-6-rpms)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Dependencies resolve and install completes.

Additional info:
N/A

Comment 1 RHEL Product and Program Management 2014-08-04 22:13:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2014-08-06 14:36:25 UTC
What repositories are enabled on your machine?

Comment 4 Brett Thurber 2014-08-06 15:07:38 UTC
subscription-manager repos --enable rhel-6-server-rpms --enable rhel-server-rhscl-6-rpms --enable rhel-server-6-satellite-6-beta-rpms

Repo ID:   rhel-6-server-rpms
Repo Name: Red Hat Enterprise Linux 6 Server (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/os
Enabled:   1

Repo ID:   rhel-server-6-satellite-6-beta-rpms
Repo Name: Red Hat Satellite 6.0 Beta (for RHEL 6 Server) (RPMs)
Repo URL:  https://cdn.redhat.com/content/beta/rhel/server/6/6Server/$basearch/satellite/6/os
Enabled:   1

Repo ID:   rhel-server-rhscl-6-rpms
Repo Name: Red Hat Software Collections RPMs for Red Hat Enterprise Linux 6 Server
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/rhscl/1/os
Enabled:   1

# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:
Internal Server Error
katello-local                                                                                                                     | 3.8 kB     00:00 ... 
rhel-6-server-rpms                                                                                                                | 3.7 kB     00:00     
rhel-6-server-rpms/primary_db                                                                                                     |  27 MB     00:09     
rhel-server-6-satellite-6-beta-rpms                                                                                               | 4.1 kB     00:00     
rhel-server-rhscl-6-rpms                                                                                                          | 3.1 kB     00:00     
repo id                                                repo name                                                                                   status
katello-local                                          katello-local                                                                                  334
rhel-6-server-rpms                                     Red Hat Enterprise Linux 6 Server (RPMs)                                                    12,794
rhel-server-6-satellite-6-beta-rpms                    Red Hat Satellite 6.0 Beta (for RHEL 6 Server) (RPMs)                                          334
rhel-server-rhscl-6-rpms                               Red Hat Software Collections RPMs for Red Hat Enterprise Linux 6 Server                      1,265
repolist: 14,727

Comment 5 Bryan Kearney 2014-08-11 20:09:52 UTC
are there any other repos on your machine? No one else is seeing this that we know of.

Comment 6 Brett Thurber 2014-09-02 01:56:41 UTC
I plan to revisit this again in the next week or so.  Will provide results when complete.

Comment 7 Bryan Kearney 2014-09-11 19:37:51 UTC
I assume with the GA that this is now resolved, Can you please confirm?

Comment 8 Bryan Kearney 2014-09-26 19:11:17 UTC
Any updates? we are not seeing examples of installs not working. I would like to close this out if it is not an issue.

Comment 9 Brett Thurber 2014-09-26 19:34:51 UTC
Apologies for the delay.  We are starting Sat 6 work next week and will update once we have results.  Thanks!

Comment 10 Brett Thurber 2014-10-28 13:09:47 UTC
This issue seems to have been resolved.  Closing.