Bug 1126919

Summary: [RFE] activation keys that have one or more of the associated subscriptions fully consumed should be indicated as unavailable
Product: Red Hat Satellite 6 Reporter: Tom McKay <tomckay>
Component: Activation KeysAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED WONTFIX QA Contact: Perry Gagne <pgagne>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, bkearney, brcoca
Target Milestone: UnspecifiedKeywords: FutureFeature
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/6938
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-30 14:22:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1122832    

Description Tom McKay 2014-08-05 15:15:35 UTC
Since subscriptions attached to an actkey are not consumed at that point but only referenced, there can be a time when one or more of the subs themselves have no more quantity left. This will result in any attempt to use the act key to register to fail.

Indicating this in the UI will be very useful to avoid user confusion during debug of registration failures.

Comment 1 Tom McKay 2014-08-05 15:15:36 UTC
Created from redmine issue http://projects.theforeman.org/issues/6938

Comment 3 Bryan Kearney 2015-08-25 17:59:57 UTC
Upstream bug component is WebUI

Comment 4 Bryan Kearney 2015-08-25 20:04:04 UTC
Upstream bug component is WebUI

Comment 5 Bryan Kearney 2015-08-25 20:24:05 UTC
Upstream bug component is Activation Keys

Comment 6 Bryan Kearney 2017-05-30 14:22:51 UTC
Thank you for your interest in Satellite 6. We have evaluated this feature request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.