Bug 1127

Summary: diff -r /dev
Product: [Retired] Red Hat Linux Reporter: frank
Component: diffutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.2CC: frank, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-09-11 15:11:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description frank 1999-02-12 03:02:16 UTC
The following is an error in the diff command.  When
comparing devices in a subdirectory, diff does not recognize
files as the same device even though they may be.

[root@frank /root]# diff d*
File d1/fd is a block special file while file d2/fd is a
block special file
[root@frank /root]# ls -l d*
d1:
total 0
brw-rw-r--   1 root     root       2,   0 Feb 11 21:51 fd

d2:
total 0
brw-rw-r--   1 root     root       2,   0 Feb 11 21:51 fd
[root@frank /root]#

Comment 1 Tim Waugh 2000-09-11 15:05:31 UTC
I can reproduce this.

Comment 2 Tim Waugh 2000-09-11 15:11:30 UTC
This behaviour seems to be mandated by POSIX and Single UNIX.