Bug 1127130

Summary: [Testing Report] Untagged does not display when some plans have no tags.
Product: [Other] TCMS Reporter: Tingting Zhao <tzhao>
Component: ApplicationAssignee: cqi
Status: NEW --- QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.8.10CC: cqi, dli, junzhang, leiwang, ryang, vchen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tingting Zhao 2014-08-06 08:34:58 UTC
Description of problem:
as summary

Version-Release number of selected component (if applicable):
v3.8.10-1 on devel server

How reproducible:
100%

Steps to Reproduce:
1.create a product named "tzhao test product",which has three builds and three versions
2.create three plans ,only one plan has tag,the other two have no tags
3.enter into the testing report ,choose this product and generate report by Plan's Tag and check whether the "Untagged" tag display in the page.

report page is:https://tcms-devel.app.eng.nay.redhat.com/report/testing/?r_product=344&r_created_since=&r_created_before=&report_type=runs_with_rates_per_plan_tag

Actual results:
step 3:there is no "Untagged" tag showing in the page.
But if you generate report by By Plan's Tag Per Tag View,you can see the "Untagged" tag display in the page.

Expected results:
after step 3: the untagged should display in the page as there are two plans having no tags.

Additional info:

Comment 1 cqi 2014-08-08 07:11:09 UTC
No passed or failed case runs are associated with those untagged plans. So, those plans do not appear in the statistics data set.