Bug 1127378

Summary: Login banner disappears upon failed login or after gnome3 screen-shield activation.
Product: Red Hat Enterprise Linux 7 Reporter: amit yadav <ayadav>
Component: gnome-shellAssignee: Florian Müllner <fmuellner>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 7.0CC: ayadav, howey.vernon, riehecky, rstrode
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-31 13:48:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1205796, 1133060    

Description amit yadav 2014-08-06 18:56:34 UTC
Description of problem:

On boot, the banner is present.  Enter a username (valid or invalid), enter a bad password twice. The login page resets, requesting a username again, but without the banner.

This same thing can be seen by entering a username (valid or invalid) and then clicking "cancel".

Login banner works well until the screen shield starts and rolls down a clock and date display. After that the banner is gone. 

Also it prompts twice for username. Restarting gdm returns the banner.

Version-Release number of selected component (if applicable):

gdm-3.8.4-28.el7_0.1.x86_64
gnome-shell-3.8.4-32.el7_0.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set login banner in RHEL7
2. Enter a username (valid or invalid), enter a bad password twice.
  
   Or Enter username (valid or invalid) and then click "cancel".

   Or Wait for screen shield(screen losk) to start. 

3. After that the banner is gone. 


Actual results:
Banner disappears

Expected results:
Banner should not disappear and it should not ask twice for username.

Additional info:

Tried to disable lock-screen using dconf-editor and gsettings to workaround this issue:

   gsettings set org.gnome.desktop.session idle-delay 0
   gsettings set org.gnome.desktop.lockdown disable-lock-screen true
   gsettings set org.gnome.desktop.screensaver lock-enabled true

Also tried gnome-shell extensions:

  https://extensions.gnome.org/extension/730/curtains-up/
  https://extensions.gnome.org/extension/672/disable-screen-shield/
  
But nothing worked.

Comment 7 Ray Strode [halfline] 2015-03-31 13:48:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2015-0535.html