Bug 1127518

Summary: xemacs: subr-fsf is missing in new version
Product: [Fedora] Fedora Reporter: Vincent Batts <vbatts>
Component: xemacs-packages-extraAssignee: Jerry James <loganjerry>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: loganjerry, steve.traylen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xemacs-packages-extra-20140715-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-16 22:31:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1099206    

Description Vincent Batts 2014-08-07 03:30:36 UTC
Description of problem:
during the build of the golang rpm, it byte compiles go-mode for emacs and xemacs. With the upgrade from xemacs-packages-extra-20130408-3 to 20140705-1, the xemacs file "subr-fsf" is no longer available

Version-Release number of selected component (if applicable):
golang-1.2.2
xemacs-packages-extra-20140705-1

How reproducible:
consistent

Steps to Reproduce:
1. git clone git://pkgs.fedoraproject.org/golang.git && cd golang && git checkout golang-1.2.2-10.fc20 && fedpkg --dist f20 mockbuild
2. review the build.log
3.

Actual results:
+ /usr/bin/xemacs -q -no-site-file -batch -eval '(push "." load-path)' -f batch-byte-compile xemacs/go-mode.el
Compiling /builddir/build/BUILD/go/misc/xemacs/go-mode.el...
While compiling toplevel forms in file /builddir/build/BUILD/go/misc/xemacs/go-mode.el:
  !! File error (("Cannot open load file" "subr-fsf"))
>>Error occurred processing xemacs/go-mode.el: Cannot open load file: "subr-fsf"

Expected results:
+ /usr/bin/xemacs -q -no-site-file -batch -eval '(push "." load-path)' -f batch-byte-compile xemacs/go-mode.el
Compiling /builddir/build/BUILD/go/misc/xemacs/go-mode.el...  
While compiling toplevel forms in file /builddir/build/BUILD/go/misc/xemacs/go-mode.el:
  ** assignment to free variable bidi-paragraph-direction
While compiling go-remove-unused-imports:            
  ** reference to free variable flymake-mode
While compiling godef-jump:
  ** reference to free variable find-tag-marker-ring
While compiling go--coverage-parse-file:
  ** variable num bound but not referenced
While compiling the end of the data:  
  ** The following functions are not known to be defined:   
    go--kill-whole-line, prog-mode, flymake-mode-off, flymake-mode-on,
    go--position-bytes, make-overlay, overlay-put, remove-overlays  
Wrote /builddir/build/BUILD/go/misc/xemacs/go-mode.elc


Additional info:

Comment 1 Jerry James 2014-08-07 15:18:26 UTC
Fixing component.

This is due to a Makefile bug, already fixed in upstream's mercurial repository.  I'll make a new build to fix this.  Thanks for the report.

Comment 2 Fedora Update System 2014-08-07 20:27:17 UTC
xemacs-packages-extra-20140715-1.fc20,xemacs-packages-base-20140715-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xemacs-packages-extra-20140715-1.fc20,xemacs-packages-base-20140715-1.fc20

Comment 3 Jerry James 2014-08-07 20:29:10 UTC
I have submitted a build override for the fixed package so you can build go mode.  Run "koji wait-repo f20-build --build=xemacs-packages-extra-20140715-1.fc20" to see when it is available.

Comment 4 Fedora Update System 2014-08-08 08:36:53 UTC
Package xemacs-packages-extra-20140715-1.fc20, xemacs-packages-base-20140715-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xemacs-packages-extra-20140715-1.fc20 xemacs-packages-base-20140715-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9262/xemacs-packages-extra-20140715-1.fc20,xemacs-packages-base-20140715-1.fc20
then log in and leave karma (feedback).

Comment 5 Vincent Batts 2014-08-08 15:41:21 UTC
is this new version xemacs-packages-extra going to be pushed to f19 and el6 too?

Comment 6 Jerry James 2014-08-08 18:52:38 UTC
F19 still has version 20130408-1, which doesn't have the bug.  Unless there is a compelling reason to update it, I do not plan to do so.

The xemacs, xemacs-packages-base, and xemacs-packages-extra builds for EPEL are managed by Steve Traylen.  You will have to get his attention for an answer to that question.  However, I see that el6 has an even older set of packages, namely 20100727-1, so it also should not suffer from this bug.

And I just realized that it was you who tried to chat with me on gmail yesterday.  Sorry about that.  I regularly get spammers/phishers trying to chat with me, so I've gotten into the habit of glancing at the name and clicking on the reject button if I don't instantly recognize the name.  Yours hadn't stuck in my brain yet, I'm afraid.  Anyway, I wasn't intentionally snubbing you.  I just have a hair trigger on my finger when spammers might be involved.

Comment 7 Fedora Update System 2014-08-16 22:31:15 UTC
xemacs-packages-extra-20140715-1.fc20, xemacs-packages-base-20140715-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.