Bug 1127700

Summary: pvmove prints out a superfluous warning about skipping mirrored LV but does the move.
Product: Red Hat Enterprise Linux 6 Reporter: Nenad Peric <nperic>
Component: lvm2Assignee: Peter Rajnoha <prajnoha>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.6CC: agk, heinzm, jbrassow, msnitzer, prajnoha, prockai, tlavigne, zkabelac
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lvm2-2.02.109-2.el6 Doc Type: Bug Fix
Doc Text:
This bug did not appear in official RHEL release. No documentation needed.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-14 08:25:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
pvmove -vvvv none

Description Nenad Peric 2014-08-07 11:25:31 UTC
Description of problem:

When pvmove is done on a device in a mirror LV in cluster, LVM reports it is skipping mirror LV, although does complete the move.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime


Steps to Reproduce:

[root@virt-064 ~]# pvmove /dev/sdd1 /dev/sdf1
  Skipping mirror LV mirr_lv
  /dev/sdd1: Moved: 0.2%
  /dev/sdd1: Moved: 34.2%
  /dev/sdd1: Moved: 72.3%
  /dev/sdd1: Moved: 100.0%

Actual results:

pvmove is completed, but there is a superfluous and maybe even confusing warning message. 

Expected results:

Complete the move normally without printing out that LVM is skipping a mirror volume it actually is working on properly. 

Additional info:
This was noticed while verifying Bug #960396

Comment 2 Nenad Peric 2014-08-07 12:36:03 UTC
[root@virt-063 ~]# vgcreate vg /dev/sd{b..g}1
  Clustered volume group "vg" successfully created
[root@virt-063 ~]# lvcreate --type mirror -m 2 -n mirr_lv -L2G vg
  Logical volume "mirr_lv" created

[root@virt-063 ~]# lvs -a -o +devices
  LV                 VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log          Cpy%Sync Convert Devices                                                    
  mirr_lv            vg         mwi-a-m---   2.00g                                mirr_lv_mlog 100.00           mirr_lv_mimage_0(0),mirr_lv_mimage_1(0),mirr_lv_mimage_2(0)
  [mirr_lv_mimage_0] vg         iwi-aom---   2.00g                                                              /dev/sdb1(0)                                               
  [mirr_lv_mimage_1] vg         iwi-aom---   2.00g                                                              /dev/sdc1(0)                                               
  [mirr_lv_mimage_2] vg         iwi-aom---   2.00g                                                              /dev/sdd1(0)                                               
  [mirr_lv_mlog]     vg         lwi-aom---   4.00m                                                              /dev/sdg1(0)                                               
  lv_root            vg_virt063 -wi-ao----   6.71g                                                              /dev/vda2(0)                                               
  lv_swap            vg_virt063 -wi-ao---- 816.00m                                                              /dev/vda2(1718)                                            

[root@virt-063 ~]# pvs
  PV         VG         Fmt  Attr PSize  PFree 
  /dev/sdb1  vg         lvm2 a--  15.00g 13.00g
  /dev/sdc1  vg         lvm2 a--  15.00g 13.00g
  /dev/sdd1  vg         lvm2 a--  15.00g 13.00g
  /dev/sde1  vg         lvm2 a--  15.00g 15.00g
  /dev/sdf1  vg         lvm2 a--  15.00g 15.00g
  /dev/sdg1  vg         lvm2 a--  15.00g 14.99g
  /dev/sdh1             lvm2 ---  15.00g 15.00g
  /dev/sdi1             lvm2 ---  15.00g 15.00g
  /dev/vda2  vg_virt063 lvm2 a--   7.51g     0 

[root@virt-063 ~]# pvmove /dev/sdb1 /dev/sde1
  Skipping mirror LV mirr_lv
  /dev/sdb1: Moved: 0.4%
  /dev/sdb1: Moved: 44.5%
  /dev/sdb1: Moved: 85.0%
  /dev/sdb1: Moved: 100.0%


Will do the same thing again but with more verbose output. Will attach to the BZ.

Comment 3 Nenad Peric 2014-08-07 12:39:19 UTC
Created attachment 924898 [details]
pvmove -vvvv

Comment 4 Nenad Peric 2014-08-07 12:46:08 UTC
If a VG holding the LV is non-clustered, the message is not being displayed:

[root@virt-064 ~]# vgs
  VG         #PV #LV #SN Attr   VSize  VFree 
  single       5   1   0 wz--n- 74.98g 72.98g
  vg_virt064   1   2   0 wz--n-  7.51g     0 
[root@virt-064 ~]# 

[root@virt-064 ~]# lvs -a -o+devices
  LV                     VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log              Cpy%Sync Convert Devices                                        
  mirr_single            single     mwi-a-m---   1.00g                                mirr_single_mlog 100.00           mirr_single_mimage_0(0),mirr_single_mimage_1(0)
  [mirr_single_mimage_0] single     iwi-aom---   1.00g                                                                  /dev/sdb1(0)                                   
  [mirr_single_mimage_1] single     iwi-aom---   1.00g                                                                  /dev/sdc1(0)                                   
  [mirr_single_mlog]     single     lwi-aom---   4.00m                                                                  /dev/sdf1(0)                                   
  lv_root                vg_virt064 -wi-ao----   6.71g                                                                  /dev/vda2(0)                                   
  lv_swap                vg_virt064 -wi-ao---- 816.00m                                                                  /dev/vda2(1718)                                

[root@virt-064 ~]# pvmove /dev/sdb1 /dev/sde1
  /dev/sdb1: Moved: 0.8%
  /dev/sdb1: Moved: 100.0%

[root@virt-064 ~]# lvs -a -o+devices
  LV                     VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log              Cpy%Sync Convert Devices                                        
  mirr_single            single     mwi-a-m---   1.00g                                mirr_single_mlog 100.00           mirr_single_mimage_0(0),mirr_single_mimage_1(0)
  [mirr_single_mimage_0] single     iwi-aom---   1.00g                                                                  /dev/sde1(0)                                   
  [mirr_single_mimage_1] single     iwi-aom---   1.00g                                                                  /dev/sdc1(0)                                   
  [mirr_single_mlog]     single     lwi-aom---   4.00m                                                                  /dev/sdf1(0)                                   
  lv_root                vg_virt064 -wi-ao----   6.71g                                                                  /dev/vda2(0)                                   
  lv_swap                vg_virt064 -wi-ao---- 816.00m                                                                  /dev/vda2(1718)

Comment 5 Peter Rajnoha 2014-08-07 13:36:16 UTC
It seems we forgot to change the code checking pvmove, it's just a spurious message issued. It should be fixed with this patch:

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=ea662ca06065d1e3d44814b54cf8501c9bb9594f

Comment 8 Nenad Peric 2014-08-20 12:14:30 UTC
With the 109-1 packages the message is no longer displayed.

[root@virt-065 ~]# pvmove --atomic /dev/sdb1 /dev/sde1
  /dev/sdb1: Moved: 0.2%
  /dev/sdb1: Moved: 25.3%
  /dev/sdb1: Moved: 49.8%
  /dev/sdb1: Moved: 75.1%
  /dev/sdb1: Moved: 100.0%

marking VERIFIED with:

lvm2-2.02.109-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
lvm2-libs-2.02.109-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
lvm2-cluster-2.02.109-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
udev-147-2.57.el6    BUILT: Thu Jul 24 15:48:47 CEST 2014
device-mapper-1.02.88-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
device-mapper-libs-1.02.88-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
device-mapper-event-1.02.88-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
device-mapper-event-libs-1.02.88-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014
device-mapper-persistent-data-0.3.2-1.el6    BUILT: Fri Apr  4 15:43:06 CEST 2014
cmirror-2.02.109-1.el6    BUILT: Tue Aug  5 17:36:23 CEST 2014

Comment 9 errata-xmlrpc 2014-10-14 08:25:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1387.html