Bug 1127905

Summary: [Hyper-V][RHEL6.6]Install HyperV daemons by default
Product: Red Hat Enterprise Linux 6 Reporter: Abhishek Gupta <abgupta>
Component: distributionAssignee: Václav Pavlín <vpavlin>
Status: CLOSED DUPLICATE QA Contact: Nobody <nobody>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.6CC: dnie, jingli, leiwang, shwang, thozza, v-chvale, vpavlin, vyadav, xuli, yacao
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-21 11:23:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Hyper-V package not available at installation
none
hyperv-daemons pkg in Anaconda package selection none

Description Abhishek Gupta 2014-08-07 19:38:13 UTC
Currently the Hyper-V daemons have to be manually installed by customers using the following commands:

rpm -ivh hyperv-daemons-license-0-0.15.20130826git.el6.noarch.rpm
rpm -ivh hypervvssd-0-0.15.20130826git.el6.x86_64.rpm
rpm -ivh hypervkvpd-0-0.15.20130826git.el6.x86_64.rpm
rpm -ivh hypervfcopyd-0-0.15.20130826git.el6.x86_64.rpm
rpm -ivh hyperv-daemons-0-0.15.20130826git.el6.x86_64.rpm

Please can we automatically install these packages whenever a guest is being installed on Hyper-V? This has been achieved on RHEL 7 and we would request you to do the same on RHEL 6.6.

Thanks,
Abhishek

Comment 2 dnie 2014-08-08 02:52:47 UTC
    I check it. At present If you want auto install hyperv-daemons you need check "Virtualization->hyperv-daemons(Optional Packages)". The choice not be checked by default.

Comment 3 Tomáš Hozza 🤓 2014-08-08 08:27:37 UTC
Hi Abhishek.

Thank you for your report. I don't what you mean by "it has been achieved in RHEL-7" since Bug #1047393 is still not resolved.

As pointed out by dnie, user can select just "hyperv-daemons" package and all daemons will be installed to the system.

Moving to distribution, as the RHEL-7 bug is also filed for distribution.

This is basically duplicate of RHEL-7 Bug #1047393.

Comment 4 Václav Pavlín 2014-08-08 10:04:27 UTC
Hi Abhishek,

To install these packages automatically on Hyper-V you would need bz#884385 backported for RHEL6 and I don't think it is so critical feature that Anaconda developers would like to do it (but you can try).

Anyway in RHEL6.6 you will get all Hyper-V daemons installed by one package (hyperv-daemons) as Tomas wrote in previous comment.

I don't think installing them by default in all installations makes sense.

I am setting devel_ack- but feel free to provide more arguments and we can reconsider your request.

Comment 5 RHEL Product and Program Management 2014-08-08 10:05:49 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 6 Abhishek Gupta 2014-08-08 20:31:29 UTC
Hi Vaclav, 

We request you to reconsider the request for the following reasons:

a) These daemons are integral part of the integration services. Some of the functionality will not work unless these daemons are installed. As an example, customers cannot backup virtual machines until the backup daemon is installed. Similarly, customers cannot read IP addresses from within the guest until the KVP daemon is installed. Due to the close dependency of features on the daemons it is important that the daemons are running always.

b) The mechanism to currently install the daemons is not easily discoverable and most customers forget to install them. This generates some support calls and also the customer experience is not smooth.

We believe fixing this problem with improve RHEL experience for customers so please reconsider this request.

Thanks,
Abhishek

Comment 7 Tomáš Hozza 🤓 2014-08-11 11:49:26 UTC
If installed by default, it should not cause any issues other than occupying a disk space with unneeded daemons.

All daemons have a condition built into the start function of initscript, so they won't start if there is no HyperV.

Comment 8 Chris 2014-08-19 13:13:17 UTC
Hello,
On 6.6 Beta1 x86 the Hyper-V package(s) are not listed at all in the Virtualization section, please see the attached screenshot.

Comment 9 Chris 2014-08-19 13:13:55 UTC
Created attachment 928358 [details]
Hyper-V package not available at installation

Comment 10 Yaju Cao 2014-08-20 09:20:28 UTC
(In reply to Chris from comment #8)
> Hello,
> On 6.6 Beta1 x86 the Hyper-V package(s) are not listed at all in the
> Virtualization section, please see the attached screenshot.

I have tried with this. I also can not find the entry to install hyperv-daemons when use ISO install RHEL6.6. Maybe there are some options missed out.

Actually there is group "virtualization" which contains "hyperv-daemons" as optional package(btw another group "virtualization-tools" is also not listed) in the tree repodata. But I don't know why it is not listed on the ISO install GUI.

Comment 11 Václav Pavlín 2014-08-20 11:32:12 UTC
Created attachment 928768 [details]
hyperv-daemons pkg in Anaconda package selection

Hi, I've tried RHEL6.6 for you and this is what I got - Virtualization group provides hyperv-daemons package.

Comment 12 Chris 2014-08-20 15:47:43 UTC
Hi Vaclav,
You are using the x86_64 - 64bit ISO there, and on that architecture the hyperv-daemons package is being shown.

The problem reported in Comment #8 is that the package is not displayed on the i386 - x86 ISO installation.

Comment 13 Yaju Cao 2014-08-21 01:42:07 UTC
Yes I also tried with i386 install in my Comment 10, the result is same as Comment 8.

Comment 14 Václav Pavlín 2014-08-21 11:23:11 UTC
Ok, thanks guys, we probably know the reason why you don't see the group in installer - qemu-kvm is part of @virtualization group but is not shipped for i386, thus whole group is hidden from i386 users. 

In bz 1132401 I requested creation of @guest-agents group which will be visible in installer and will contain only guest agents (i. e. hyperv-daemons)

Anyway, I really don't think we want hyperv-daemons installed by default.

*** This bug has been marked as a duplicate of bug 1132401 ***