Bug 1128203

Summary: hammer import all broken due to change in hammer requesting admin-pwd
Product: Red Hat Satellite 6 Reporter: Grant Gainey <ggainey>
Component: TransitionsAssignee: Grant Gainey <ggainey>
Status: CLOSED NOTABUG QA Contact: Lukas Pramuk <lpramuk>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: cperry, ggainey, mkollar
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-08 15:08:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1125243    

Description Grant Gainey 2014-08-08 14:51:56 UTC
Used to was, hammer didn't ask for the Foreman password. This was changed.  'all' doesn't know about the change.  API-access from 'all' fails because 'all' doesn't give the password.

Need to add two new options to 'all':

--username LOGIN : who should we connect to Sat6 as, defaults to 'admin'
--password PWD : what password should we use, required, no default

Comment 1 Grant Gainey 2014-08-08 15:08:36 UTC
closing - pwd comes from cfg, and has to be set correctly after reinstalling