Bug 1128279

Summary: ld copies SONAME to DT_NEEDED without checking if it’s empty
Product: Red Hat Enterprise Linux 6 Reporter: Jeff Law <law>
Component: binutilsAssignee: Patsy Franklin <pfrankli>
Status: CLOSED ERRATA QA Contact: Miloš Prchlík <mprchlik>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.6CC: btotty, jonstanley, law, mcermak, mfranc, mnewsome, mpolacek, ohudlick, pfrankli
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: binutils-2.20.51.0.2-5.42.el6 Doc Type: Bug Fix
Doc Text:
Cause: The linker will overwrite a valid SONAME with an empty string in a DT_NEEDED record. Consequence: Certain programs will link, but not execute because symbols from some libraries will not be loaded. Fix: The linker correctly handles empty strings in SONAMES. Result: Programs execute as expected.
Story Points: ---
Clone Of: 1117458 Environment:
Last Closed: 2014-10-14 04:41:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1117458    
Bug Blocks:    

Comment 4 Miloš Prchlík 2014-08-15 14:10:02 UTC
Verified for build binutils-2.20.51.0.2-5.42.el6.

Comment 5 errata-xmlrpc 2014-10-14 04:41:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1414.html