Bug 1128521

Summary: Icehouse yum mongodb-server not found
Product: [Community] RDO Reporter: Mark Yavorski <kramik1>
Component: openstack-packstackAssignee: Martin Magr <mmagr>
Status: CLOSED CURRENTRELEASE QA Contact: Ami Jeain <ajeain>
Severity: high Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: aortega, derekh, lars, yeylon
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-28 20:44:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mark Yavorski 2014-08-11 02:25:55 UTC
When attempting to install openstack via RDO on CentOS 6.5 it receives package not found error for mongodb.  It seems that epel does not have mongodb-server in it anymore.  Many epel package listings do not have it anymore.  (ie https://apps.fedoraproject.org/packages/mongodb-server/contents)  I added the mongo-10gen-server repo from mongodb-org but the install still attempted to find the package.  New to RDO so it took me a number of hours to hunt down and adjust the server_install_spec.rb and params.pp files within openstack-puppet so that it would search yum for the new package name (mong-10gen-server or mongodb-org-server).  To get it working without issue.  Surprised that this hasn't been found soon actually.

Directory of adjusted files are:
/usr/share/openstack-puppet/modules/mongodb/spec/classes/server_install_spec.rb
/usr/share/openstack-puppet/modules/mongodb/manifests/params.pp

Comment 1 Lars Kellogg-Stedman 2015-03-28 20:44:06 UTC
mongodb-server was briefly dropped from EPEL but has since been restored, and I am able to successfully install the package on a CentOS 6/EPEL system.