Bug 1128729

Summary: No timeout when requesting data by ovirt optimizer
Product: [Retired] oVirt Reporter: Lukas Svaty <lsvaty>
Component: ovirt-engine-coreAssignee: Martin Sivák <msivak>
Status: CLOSED CURRENTRELEASE QA Contact: Lukas Svaty <lsvaty>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.5CC: ecohen, gklein, iheim, mavital, rbalakri, yeylon
Target Milestone: ---Keywords: Triaged
Target Release: 3.5.0   
Hardware: All   
OS: All   
Whiteboard: sla
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-17 12:43:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: SLA RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lukas Svaty 2014-08-11 12:34:04 UTC
Description of problem:
Status: Waiting for data... is displayed all the time even if data is not acquired by ovirt optimizer. In case of network issue or ui plugin pointing to bad network location admin should be notified about this fact

Version-Release number of selected component (if applicable):
ovirt-rc1

How reproducible:
100%

Steps to Reproduce:
1. Set optimizer-ui plugin to random address
2. Wait for data that will never come

Actual results:
Status: Waiting for data..

Expected results:
Error in events, or some kind of notification for admin.

Comment 1 Martin Sivák 2014-08-26 11:38:07 UTC
Fixed in the current version.

Comment 2 Sandro Bonazzola 2014-10-17 12:43:56 UTC
oVirt 3.5 has been released and should include the fix for this issue.