Bug 1128733

Summary: rubygem-rhc depends on a newer version of rubygem-net-scp then what is in the repos
Product: [Fedora] Fedora EPEL Reporter: Wesley Hearn <whearn>
Component: rubygem-net-scpAssignee: Troy Dawson <tdawson>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-13 14:32:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Wesley Hearn 2014-08-11 12:45:38 UTC
Description of problem:
Unable to install rubygem-rhc due to rubygem-net-scp being out of date

Version-Release number of selected component (if applicable):
rubygem-rhc-1.27.4-1.el7.noarch
rubygem-net-scp-1.0.4-7.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL7 Workstation
2. Enable EPEL
3. yum install rubygem-rhc

Actual results:
[root@Desktop ~]# yum install rubygem-rhc
Loaded plugins: langpacks, product-id, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package rubygem-rhc.noarch 0:1.27.4-1.el7 will be installed
--> Processing Dependency: rubygem-net-ssh-multi >= 1.2.0 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-net-ssh >= 2.0.11 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-net-scp >= 1.1.2 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-httpclient >= 2.2 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-highline >= 1.6.11 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-commander >= 4.0 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-test-unit for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-open4 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-archive-tar-minitar for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Running transaction check
---> Package rubygem-archive-tar-minitar.noarch 0:0.5.2-10.el7 will be installed
---> Package rubygem-commander.noarch 0:4.1.2-7.el7 will be installed
---> Package rubygem-highline.noarch 0:1.6.11-5.el7 will be installed
---> Package rubygem-httpclient.noarch 0:2.3.2-7.el7 will be installed
---> Package rubygem-net-ssh.noarch 0:2.9.1-1.el7 will be installed
---> Package rubygem-open4.noarch 0:1.3.0-5.el7 will be installed
---> Package rubygem-rhc.noarch 0:1.27.4-1.el7 will be installed
--> Processing Dependency: rubygem-net-ssh-multi >= 1.2.0 for package: rubygem-rhc-1.27.4-1.el7.noarch
--> Processing Dependency: rubygem-net-scp >= 1.1.2 for package: rubygem-rhc-1.27.4-1.el7.noarch
---> Package rubygem-test-unit.noarch 0:2.5.5-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: rubygem-rhc-1.27.4-1.el7.noarch (epel)
           Requires: rubygem-net-ssh-multi >= 1.2.0
Error: Package: rubygem-rhc-1.27.4-1.el7.noarch (epel)
           Requires: rubygem-net-scp >= 1.1.2
           Available: rubygem-net-scp-1.0.4-7.el7.noarch (epel)
               rubygem-net-scp = 1.0.4-7.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
All deps should be resolved and rubygem-rhc should install.

Additional info:

Comment 1 Troy Dawson 2014-08-11 13:45:59 UTC
Working on this.
Look like we need the newer version of rubygem-net-ssh-multi as well.

Comment 2 Troy Dawson 2014-08-11 22:28:59 UTC
OK, the full list is
rubygem-net-scp >= 1.1.2
rubygem-net-ssh-multi >= 1.2.0
rubygem-net-ssh-gateway

I already have rubygem-net-scp updates.
I have requests for EPEL7 build queues for the other two.

Comment 3 Troy Dawson 2014-08-13 14:32:20 UTC
All dependencies of rubygem-rhc are now available on EPEL7.