Bug 1128858

Summary: SELinux is preventing /usr/bin/fusermount from 'unmount' accesses on the filesystem .
Product: [Fedora] Fedora Reporter: Moez Roy <moez.roy>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:dc2f59c80e66740e7ff798848c59f4560aeb5c0af7844b0049d790ab8f7be6a2
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-12 12:14:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Moez Roy 2014-08-11 16:07:44 UTC
Description of problem:
SELinux is preventing /usr/bin/fusermount from 'unmount' accesses on the filesystem .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fusermount should be allowed unmount access on the  filesystem by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep fusermount /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:fusefs_t:s0
Target Objects                 [ filesystem ]
Source                        fusermount
Source Path                   /usr/bin/fusermount
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           fuse-2.9.3-3.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-71.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-1.fc21.x86_64 #1 SMP Mon
                              Aug 4 10:01:25 UTC 2014 x86_64 x86_64
Alert Count                   4
First Seen                    2014-08-11 08:51:48 PDT
Last Seen                     2014-08-11 08:57:04 PDT
Local ID                      490b3c15-9804-42b3-a6b5-906d4a3c8f07

Raw Audit Messages
type=AVC msg=audit(1407772624.197:544): avc:  denied  { unmount } for  pid=4425 comm="fusermount" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fusefs_t:s0 tclass=filesystem permissive=1


type=SYSCALL msg=audit(1407772624.197:544): arch=x86_64 syscall=umount2 success=yes exit=0 a0=1fca64d a1=a a2=0 a3=36a items=0 ppid=4231 pid=4425 auid=4294967295 uid=42 gid=42 euid=0 suid=0 fsuid=0 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm=fusermount exe=/usr/bin/fusermount subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: fusermount,xdm_t,fusefs_t,filesystem,unmount

Version-Release number of selected component:
selinux-policy-3.13.1-71.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-1.fc21.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-08-12 12:14:13 UTC

*** This bug has been marked as a duplicate of bug 1128859 ***