Bug 1129510

Summary: Need instruction for adding "-Dfile.encoding=UTF-8" in $JBDS_HOME/studio/jbdevstudio.ini
Product: [Retired] JBoss BPMS Platform 6 Reporter: Hisao Furuichi <hfuruich>
Component: DocumentationAssignee: Vikram Goyal <vigoyal>
Status: CLOSED CURRENTRELEASE QA Contact: Marek Baluch <mbaluch>
Severity: high Docs Contact: Vikram Goyal <vigoyal>
Priority: high    
Version: 6.0.3CC: brms-docs
Target Milestone: CR2   
Target Release: One-off release   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-03 10:13:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hisao Furuichi 2014-08-13 02:19:42 UTC
Description of problem:
Need instruction for adding "-Dfile.encoding=UTF-8" in $JBDS_HOME/studio/jbdevstudio.ini. Because there is known issue which can avoid using file.encoding option:
https://access.redhat.com/solutions/911693
https://access.redhat.com/solutions/537533 (This is for BRMS 5.3.1)

Actual results:
There is no instruction about file.encoding option in "Installation Guide".

https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BPM_Suite/6.0/html-single/Installation_Guide/index.html#chap-Red_Hat_JBoss_Developer_Studio

Expected results:
There is an instruction about file.encoding option in "Installation Guide".

Comment 2 Vikram Goyal 2014-10-27 06:12:54 UTC
Thanks Hisao.

This has now been added as a warning in the JBDS intro section and can be verified here [1].

Moving this to ON_QA.

Once this has been verified, I will release this as an async update.

[1] https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_JBoss_BPM_Suite/6.0/html-single/Installation_Guide/#chap-Red_Hat_JBoss_Developer_Studio

Comment 4 Marek Baluch 2014-10-30 09:53:10 UTC
Verified using the document referenced in comment #2.