Bug 1129595

Summary: AttributeError: 'NoneType' object has no attribute 'path'
Product: Red Hat Enterprise Linux 7 Reporter: Jan Stodola <jstodola>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED ERRATA QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: python-blivet-0.61.0.5-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-05 14:02:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1112660    

Description Jan Stodola 2014-08-13 10:08:42 UTC
Description of problem:
anaconda 19.31.79-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 453, in unusedDevices
    extended = device.disk.format.extendedPartition.path
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 779, in unusedDevices
    unused_devices = [d for d in self.__storage.unusedDevices
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 946, in _do_refresh
    log.debug("ui: unused=%s" % [d.name for d in self.unusedDevices])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 872, in refresh
    self._do_refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 110, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 420, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 436, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
AttributeError: 'NoneType' object has no attribute 'path'

Version-Release number of selected component (if applicable):
RHEL-7.0 GA
anaconda 19.31.79-1

How reproducible:
always

Steps to Reproduce:
Steps:
1. start virtual machine with two disks, partitioning of the first disk is:

Number  Start   End     Size    Type      File system  Flags
 1      1049kB  211MB   210MB   primary
 2      211MB   420MB   210MB   primary
 3      420MB   630MB   210MB   primary
 4      630MB   8590MB  7960MB  extended
 5      631MB   841MB   210MB   logical

The second disk don't have a disk label.

2. go to disk selection screen and select both disks
3. go to custom partitioning ("I will configure partitioning" option)
4. remove all existing partitions and let anaconda to create LVM partitioning automatically
5. accept changes and go back to disk selection screen
6. unselect the second disk and go to custom partitioning again

Actual results:
anaconda traceback

Expected results:
user can use custom partitioning

Comment 3 Jan Stodola 2014-12-15 08:51:05 UTC
No longer able to reproduce with python-blivet-0.61.0.18-1.el7 and anaconda-19.31.111-1.el7, compose RHEL-7.1-20141204.2.

Moving to VERIFIED.

Comment 5 errata-xmlrpc 2015-03-05 14:02:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html