Bug 1129904

Summary: errors during package install on RHEL 7
Product: Red Hat Satellite 6 Reporter: Jason Montleon <jmontleo>
Component: SELinuxAssignee: Lukas Zapletal <lzap>
Status: CLOSED CURRENTRELEASE QA Contact: Elyézer Rezende <erezende>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: dcleal, lzap, sthirugn
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-11 12:18:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jason Montleon 2014-08-13 22:26:24 UTC
Description of problem:
  Installing : foreman-selinux-1.6.0.6-1.el7sat.noarch                    333/549 
libsepol.print_missing_requirements: foreman's global requirements were not met: type/attribute consoletype_exec_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
ValueError: Could not commit semanage transaction
ValueError: Type elasticsearch_port_t is invalid, must be a port type


Version-Release number of selected component (if applicable):
foreman-selinux-1.6.0.6-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum -y install katello with GA Snap 5

Actual results:
package installs with error

Expected results:
package should install without error.

Additional info:
No error results from RHEL 6 counterparts install:
  Installing : policycoreutils-python-2.0.83-19.39.el6.x86_64              233/449 
  Installing : pulp-selinux-2.4.0-0.30.beta.el6sat.noarch                  234/449 
  Installing : foreman-selinux-1.6.0.6-1.el6sat.noarch                     235/449 
  Installing : katello-installer-0.0.59-1.el6sat.noarch                    236/449

Comment 1 RHEL Product and Program Management 2014-08-13 22:42:54 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Lukas Zapletal 2014-08-14 07:10:05 UTC
Jason, sorry about that. I forgot to include one another patch for the selinux bugfixes which is in foreman-packaging (selinux package SPEC file):

https://github.com/theforeman/foreman-packaging/pull/308

This will properly setup RHEL macros so the policy works on both RHEL6 and RHEL7.

Note this patch is needed for RHEL6 as well as the RHEL7 changes can possibly break RHEL6 policy.

Comment 4 Dominic Cleal 2014-08-14 08:23:10 UTC
Moving back to POST, I can't see any commits.

Comment 6 Elyézer Rezende 2014-08-26 20:11:15 UTC
VERIFIED on Satellite-6.0.4-RHEL-7-20140823.0

Installing : policycoreutils-python-2.2.5-11.el7.x86_64               346/637
Installing : foreman-selinux-1.6.0.9-1.el7sat.noarch                  347/637
Installing : pulp-selinux-2.4.0-0.30.beta.el7sat.noarch               348/637

Comment 9 Bryan Kearney 2014-09-11 12:18:58 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.