Bug 1130391

Summary: dnf-plugins-core: copr list command fails with TypeError: must be unicode, not str
Product: [Fedora] Fedora Reporter: Mikolaj Izdebski <mizdebsk>
Component: dnf-plugins-coreAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: akozumpl, jsilhan, packaging-team-maint, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-15 09:05:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mikolaj Izdebski 2014-08-15 06:22:05 UTC
Description of problem:
copr list command fails with
TypeError: must be unicode, not str

Version-Release number of selected component (if applicable):
dnf-0.5.4-2.fc20.noarch
dnf-plugins-core-0.1.1-3.fc20.noarch

Steps to Reproduce:
dnf copr list mizdebsk

Actual results:
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1171, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/copr.py", line 132, in run
    msg = self.base.output.fmtKeyValFill(msg, desc)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 704, in fmtKeyValFill
    keylen = exact_width(key)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 164, in exact_width
    return sum(_exact_width_char(c) for c in msg)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 164, in <genexpr>
    return sum(_exact_width_char(c) for c in msg)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 138, in _exact_width_char
    return 2 if unicodedata.east_asian_width(uchar) in ('W', 'F', 'A') else 1
TypeError: must be unicode, not str

Comment 1 Honza Silhan 2014-08-15 09:05:32 UTC
Hi, thanks for the report, but duplicate.

*** This bug has been marked as a duplicate of bug 1123886 ***