Bug 1130515

Summary: SELinux is preventing /usr/bin/python2.7 from 'connectto' accesses on the unix_stream_socket .
Product: [Fedora] Fedora Reporter: Moez Roy <moez.roy>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:f11f6e7debd154e8a7db205c23d0723155df73852f666239f7a5f763b6d3a09d
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-03 14:06:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Moez Roy 2014-08-15 12:56:46 UTC
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'connectto' accesses on the unix_stream_socket .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that python2.7 should be allowed connectto access on the  unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dnssec-trigger- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Objects                 [ unix_stream_socket ]
Source                        dnssec-trigger-
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-13.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.15.9-200.fc20.x86_64 #1 SMP Sat
                              Aug 9 09:02:55 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-08-15 05:36:52 PDT
Last Seen                     2014-08-15 05:36:52 PDT
Local ID                      f7ea84ca-acf8-4175-ae14-4fb421e7b2de

Raw Audit Messages
type=AVC msg=audit(1408106212.251:1185): avc:  denied  { connectto } for  pid=6268 comm="dnssec-trigger-" path="/run/abrt/abrt.socket" scontext=system_u:system_r:init_t:s0 tcontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1408106212.251:1185): arch=x86_64 syscall=connect success=yes exit=0 a0=8 a1=7fff5ec697b0 a2=1b a3=0 items=0 ppid=1 pid=6268 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=dnssec-trigger- exe=/usr/bin/python2.7 subj=system_u:system_r:init_t:s0 key=(null)

Hash: dnssec-trigger-,init_t,abrt_t,unix_stream_socket,connectto

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.9-200.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-09-03 14:06:52 UTC

*** This bug has been marked as a duplicate of bug 1130513 ***