Bug 1130704

Summary: exfalso NameError: global name 'set_columns' is not defined
Product: [Fedora] Fedora Reporter: Dave M <davem>
Component: quodlibetAssignee: hannes <johannes.lips>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: code, davem, johannes.lips, reiter.christoph
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: quodlibet-3.2.1-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-27 01:37:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dave M 2014-08-16 13:19:57 UTC
Description of problem:
exfalso dies immediately with this:

Traceback (most recent call last):
  File "/usr/bin/exfalso", line 67, in <module>
    main()
  File "/usr/bin/exfalso", line 44, in main
    app.player = quodlibet.init_backend("nullbe", app.librarian)
  File "/usr/lib/python2.7/site-packages/quodlibet/__init__.py", line 375, in init_backend
    backend = quodlibet.player.init(backend)
  File "/usr/lib/python2.7/site-packages/quodlibet/player/__init__.py", line 47, in init
    backend = __import__(modulename, {}, {}, "quodlibet.player")
  File "/usr/lib/python2.7/site-packages/quodlibet/player/nullbe.py", line 9, in <module>
    from quodlibet.qltk.songlist import PlaylistModel
  File "/usr/lib/python2.7/site-packages/quodlibet/qltk/songlist.py", line 130, in <module>
    @config.register_upgrade_function
  File "/usr/lib/python2.7/site-packages/quodlibet/util/config.py", line 86, in register_upgrade_function
    self._do_upgrade(function)
  File "/usr/lib/python2.7/site-packages/quodlibet/util/config.py", line 55, in _do_upgrade
    func(self, old_version, new_version)
  File "/usr/lib/python2.7/site-packages/quodlibet/qltk/songlist.py", line 134, in _migrate_rating_column
    columns = get_columns()[:]
  File "/usr/lib/python2.7/site-packages/quodlibet/qltk/songlist.py", line 125, in get_columns
    set_columns(columns)
NameError: global name 'set_columns' is not defined

Version-Release number of selected component (if applicable):
exfalso-3.2-1.fc20.noarch

How reproducible:
try to start the program with this new version

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Work like it used to!

Additional info:

Comment 1 hannes 2014-08-16 16:12:20 UTC
Hi,

I can't reproduce the issue. Are you able to start quodlibet? I will try to contact upstream to find the cause of this issue.

- Johannes

Comment 2 Christoph Reiter 2014-08-16 16:22:49 UTC
See https://code.google.com/p/quodlibet/issues/detail?id=1448

The workaround is to start/quit quodlibet once. Then exfalso should work again.

Comment 3 Dave M 2014-08-16 17:43:29 UTC
Hi,

If that's the case, then shouldn't exfalso be dependent upon quodlibet?  I typically only use exfalso because I like the tagging.  I can install quodlibet to fix this... just pointing it out.

Thanks!

Comment 4 Dave M 2014-08-16 17:54:50 UTC
Also, you are correct - starting quodlibet once does fix the exfalso startup problem.

Thanks!

Comment 5 hannes 2014-08-17 07:43:14 UTC
Hi,
 
well it was a bug and normally exfalso should not depend on the start of quodlibet, but this was the easiest workaround for this problem.
I am currently in the process of updating exfalso/quodlibet to the bugfix release Christoph released.
Thanks for reporting the bug,

Johannes

Comment 6 Fedora Update System 2014-08-17 08:08:22 UTC
quodlibet-3.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/quodlibet-3.2.1-1.fc20

Comment 7 Fedora Update System 2014-08-19 07:06:25 UTC
Package quodlibet-3.2.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quodlibet-3.2.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9543/quodlibet-3.2.1-1.fc20
then log in and leave karma (feedback).

Comment 8 code 2014-08-21 11:44:31 UTC
Confirming the workaround of starting quodlibet once. (Tried it before I had a chance to test the update instead.)

Comment 9 Fedora Update System 2014-08-27 01:37:20 UTC
quodlibet-3.2.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.