Bug 1130708

Summary: root password not inherited from host group
Product: Red Hat Satellite Reporter: David Juran <djuran>
Component: WebUIAssignee: Ohad Levy <ohadlevy>
WebUI sub component: Foreman QA Contact: Katello QA List <katello-qa-list>
Status: CLOSED NOTABUG Docs Contact:
Severity: unspecified    
Priority: unspecified CC: dcleal, djuran
Version: 6.0.3   
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-19 11:30:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Juran 2014-08-16 16:17:49 UTC
Description of problem:
I've noticed that when creating a host from a host-group where the root password is filled in, I still need to enter it manually when creating the host.


How reproducible:
Every time

Steps to Reproduce:
1. Create host group with root password filled in
2. Create host from group above
3. Note how you still need to fill in the password when creating the host

Comment 1 RHEL Program Management 2014-08-16 16:22:54 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-08-18 08:10:53 UTC
Can you describe precisely why "you need to"?  Is an error shown in the web UI if you save the host?

Comment 4 David Juran 2014-08-18 13:55:02 UTC
Sorry, I should have clarified my urges (-:

Yes, if I click submit, I'm thrown back into the host creation dialogue and the root password is highlighted in red saying

"should be 8 characters or more and should not be blank - consider setting a global or host group default"

(Which is kind of ironic now that I think of it...)

The same message is also repeated in /var/log/foreman/production.log

Comment 5 Dominic Cleal 2014-08-18 14:56:08 UTC
I'm struggling to reproduce this in any way.  Could you run: sudo -u foreman psql -c 'select id,title,root_pass from hostgroups;' to list what's stored in the DB.  Perhaps also try editing the host group again and ensure the password is set.

Comment 6 David Juran 2014-08-19 11:30:25 UTC
I hope this wasn't just me being silly but after (re?)-entering the password into the host group, I was able to create the host just fine.