Bug 1130887

Summary: Executing multiple "template.delete" commands in parallel to "vm.delete" commands, creates a race condition which cause the Blank template to be removed from Data Center
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engineAssignee: Shahar Havivi <shavivi>
Status: CLOSED ERRATA QA Contact: Lukas Svaty <lsvaty>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: aburden, ecohen, gklein, iheim, lpeer, michal.skrivanek, mlipchuk, ofrenkel, rbalakri, Rhev-m-bugs, shavivi, sherold, tnisan, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: 3.4.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: virt
Fixed In Version: org.ovirt.engine-root-3.4.3-1 Doc Type: Bug Fix
Doc Text:
Previously, executing multiple 'template.delete' commands in parallel to 'vm.delete' commands would create a race condition that filled an empty template id with the 'Blank template, removing the 'Blank' template from the environment. Now, an empty template id will prompt the engine to search for and include the appropriate template id, protecting the 'Blank' template from being removed.
Story Points: ---
Clone Of: 1105211 Environment:
Last Closed: 2014-10-23 12:30:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1105211    
Bug Blocks:    

Comment 2 Lukas Svaty 2014-10-14 12:19:29 UTC
verified in av12.2

Comment 4 errata-xmlrpc 2014-10-23 12:30:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1712.html