Bug 113101

Summary: ACPI fails to load on AMD x86-64 Tyan system
Product: Red Hat Enterprise Linux 3 Reporter: John Dennis <jdennis>
Component: kernelAssignee: Jim Paradis <jparadis>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: peterm, petrides, riel
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-01-14 12:01:52 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Dennis 2004-01-08 10:30:00 EST
The ACPI subsystem is unable to load the ACPI tables because it is
unable to locate the ACPI root pointer. With ACPI debug level set to
medium the following is emitted to the syslog. Firmware is most
current AMD rev. This has been discussed with Jim Paradis who is aware
of it, opening bug mostly for tracking purposes.

acpi_find_root_pointer: RSDP structure not found, AE_NOT_FOUND Flags=8
acpi_find_root_pointer: ----Exit- ****Exception****: AE_NO_ACPI_TABLES
ACPI: System description tables not found
acpi_load_tables: Could not get RSDP, AE_NOT_FOUND
tbxface-0134: *** Error: acpi_load_tables: Could not load tables:
AE_NOT_FOUND
tbxface-0136 [03] acpi_load_tables      : ----Exit- ****Exception****:
AE_NOT_FOUND
ACPI: Unable to load the System Description Tables


Version-Release number of selected component (if applicable):
kernel-2.4.21-17.EL

How reproducible:
Always

Steps to Reproduce:
boot the system

Actual Results:  ACPI is not utilized, problems with proper device
enumeration ensue, separate bug report will be filed on that

Expected Results:  ACPI tables should have been loaded

Additional info:
Comment 1 Jim Paradis 2004-01-14 12:01:52 EST
Fixed by a BIOS update.  NOTABUG in the OS :)