Bug 1132179

Summary: Suggestion: shorten desktop launcher names
Product: [Fedora] Fedora Reporter: Elad Alfassa <elad>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-30 12:00:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
screenshot none

Description Elad Alfassa 2014-08-20 20:52:32 UTC
Hey libreoffice people!

I have a suggestion to make:

You should remove the "LibreOffice" prefix from the Name field of your desktop launchers.

The reason for this odd request is simple: the name is quite long. Having such long name means it's elipsized in GNOME Shell when using a laptop monitor, so you see 4 icons named "LibreOffice …" next to one another. This might not be a problem when you are familiar with the icons or the color scheme they use, but if you are a new user that never heard of LibreOffice you will not know which one to launch.

Wouldn't it be better if you'd show them as Writer, Calc, Draw, Impress instead? It won't harm the "libreoffice" brand because you still show that in the window title and in the splash screen. 

If you add LibreOffice to the Keywords field in the desktop file, people searching for LibreOffice in the shell would still see those icons, so it doesn't harm this usecase either.

The long name means they're also elipsized in gnome-software when they are shown in the recommended tiles on the main screen.

What do you think?

I'd understand if you'd close this bug as WONTFIX, but I do think this would make our user experience, especially on laptops, better.

Comment 1 Caolan McNamara 2014-08-21 07:22:21 UTC
Can I get a screenshot of where it get ellipsed ?

Comment 2 Elad Alfassa 2014-08-21 07:59:06 UTC
Created attachment 929093 [details]
screenshot

This is from my work laptop (so that's why there's a lot of rubbish installed) but you can clearly see the problem here. I assume it affects every 13" laptop and probably bigger ones too.

Comment 3 Caolan McNamara 2014-08-21 09:01:37 UTC
FWIW on a 1280x1024 F-20 machine I get *5* columns of icons and the full titles fit in the default font and font size fit into each column. While on another F-20 1920x1080 machine I get 6 columns, and the text fits also.

Looking at my apps, I have GIMP as "GNU Image Manipulation Program" which doesn't fit into any available one-line space :-) and a pile of other applications that have verbose titles.

Checeking my android phone the equivalent labels line wrap at the edge of the icons, giving typically two lines of text for each icon. Which seems a better more generic approach, especially as there's loads of available space between the rows.

Comment 4 Elad Alfassa 2014-08-21 11:35:41 UTC
1366x768 is still a very common resolution for laptops, and many people use laptops. It would make Fedora look more polished if at least our default apps won't have elipsized names on this display size...

Changing the way the shell display this text is something we could peruse, but even if GNOME Upstream would agree to make that change it won't happen in time for Fedora 21.

As a side note, the GNOME 3 HIG suggest an application name should be shorter than 15 characters.

Comment 5 Caolan McNamara 2014-08-30 12:00:45 UTC
Alright, I thought about it, but I'm not going to make the diff locally to our builds for this to change the name of our applications, we've played around in the past with this and its soaks up time with various unexpected sideeffects, IMO the labels should line wrap to two lines like android :-)

Comment 6 Caolan McNamara 2014-08-30 12:01:32 UTC
I mean, I have no objection to upstream renaming things of course

Comment 7 Elad Alfassa 2014-08-30 12:02:45 UTC
Fair enough. (I doubt upstream would agree to make this change either, tbh)