Bug 1135107

Summary: EAP Patch Deploy To EAP Version 6.1.0 Or Less Should Not Be Allowed To Take Place
Product: [JBoss] JBoss Operations Network Reporter: Matt Mahoney <mmahoney>
Component: Plugin -- OtherAssignee: Lukas Krejci <lkrejci>
Status: CLOSED CURRENTRELEASE QA Contact: Mike Foley <mfoley>
Severity: high Docs Contact:
Priority: unspecified    
Version: JON 3.3.0CC: lkrejci, myarboro, tsegismo
Target Milestone: ER03   
Target Release: JON 3.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-11 14:04:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1069547    

Description Matt Mahoney 2014-08-28 20:17:07 UTC
Description of problem:
Patches to EAP version 6.1.0 or less are not prevented, and thus fail due to patching not being introduced into EAP until version 6.2.0

Version-Release number of selected component (if applicable):
JON 3.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Patch deploy fails when applying to EAP 6.1.0 or less.

Expected results:
Patches deploys should be prevented when EAP version is <= 6.1.0

Additional info:

Comment 2 Lukas Krejci 2014-08-29 12:44:26 UTC
I don't exactly know how we should prevent the deployment to older versions of EAP.

There is no mechanism on the server side to discriminate members of compatible groups based on further criteria.
(I.e. I have a group of EAP servers, but I cannot say that only 2 of 3 members can be deployed to because they are of supported versions).

On the agent side, the only thing we can do is to try the deployment and maybe fail with a nicer error message than the one coming out of EAP itself.

I'd say that adding such feature is out of scope for 3.3 and I am not sure it is worth adding such capability to RHQ/JON at all at this time until we figure out the scope/functionality of provisioning in JON.Next.

Comment 3 Lukas Krejci 2014-08-29 12:57:24 UTC
To be more precise:

* I am against adding a server-side facility to discriminate between group members based on further criteria when determining the targets of deployment (at least in JON 3.3 payload)

* We can surely provide a nicer error message coming from the agent when trying to deploy to an unsupported version of EAP.

For the record, the failure message coming from EAP < 6.2.0, when attempting the patch deployment, has the following form: 

"Unexpected command 'patch apply --path=...'. Type 'help --commands' for the list of supported commands."

This is visible in JON's UI when examining the status of the failed deployment.

Comment 5 Lukas Krejci 2014-09-05 11:36:28 UTC
Fix proposed: https://github.com/rhq-project/rhq/pull/121

Comment 6 Thomas Segismont 2014-09-10 15:00:19 UTC
Merged in release/jon3.3.x

commit 4cedda3a24228c93f0621e3c0aa8dd6043043e32
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Wed Sep 10 16:57:51 2014 +0200

    BZs 1136996 1135034 1135107 - Check if patching is supported before trying to perform it on EAP based resource
    
    From patch file created with "git diff a3a59ff 5c39e3a"

Comment 7 Simeon Pinder 2014-09-17 02:49:20 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149