Bug 1135290

Summary: RHEL 6 sosreport integration for Satellite 6 Capsule server debugging
Product: Red Hat Enterprise Linux 6 Reporter: Xixi <xdmoon>
Component: sosAssignee: Shane Bradley <sbradley>
Status: CLOSED ERRATA QA Contact: Miroslav HradĂ­lek <mhradile>
Severity: medium Docs Contact:
Priority: high    
Version: 6.7CC: agk, ahumbe, bhamrick, bkearney, bmr, dkutalek, gavin, katello-bugs, katello-qa-list, lzap, mhradile, mmccune, sbradley, xdmoon
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sos-3.2-16.el6 Doc Type: Enhancement
Doc Text:
The sosreport plug-in now enables capturing data required to debug Satellite Capsule Server problems.
Story Points: ---
Clone Of: 1134109 Environment:
Last Closed: 2015-07-22 06:32:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1134109, 1135317    
Bug Blocks: 1115190    

Comment 1 Lukas Zapletal 2015-02-03 09:41:59 UTC
We have separated foreman-debug command out of the foreman RPM package, it's now distributed separately (in foreman-debug subpackage) and by default it will be installed on all Capsule servers.

Since sosreport already contains foreman-debug plugin

https://github.com/sosreport/sos/blob/master/sos/plugins/foreman.py

there is no need of any changes in sosreport I believe. When sos is executed on Satellite 6 main node, it calls foreman-debug to collect additional data. When sos is executed on Capsule node, it does the same from now on.

I suggest to close this ticket.

Comment 2 Lukas Zapletal 2015-02-03 09:44:51 UTC
To make this clear, the original foreman-debug command was capable of collecting information from foreman-proxy, the component that runs on Capsule server. In the upstream, usual deployment is to have the first proxy on the same server.

By installing the script on both Satelilite 6 and Capsule servers, we now collect all the relevant information. Both commands are the same with same (unchanged) options, so there is no need of changing anything in the sos report.

Comment 3 Bryn M. Reeves 2015-02-03 12:55:19 UTC
This bug is still required: the current foreman plugin only checks for the 'foreman' package.

Comment 4 Lukas Zapletal 2015-02-03 13:51:16 UTC
Oh haven't realized that you check against RPM packages. I was under impression that script is enough. Sure, that makes sense. FYI I issued an upstream change, this is the desired state now (and for Satellite 6.1 as well):

https://github.com/sosreport/sos/pull/488

Comment 25 errata-xmlrpc 2015-07-22 06:32:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1323.html