Bug 1136457

Summary: kde-workspace files in /usr/share/xsession should be named kde-plasma.desktop and kde-plasma-safe.desktop
Product: Red Hat Enterprise Linux 7 Reporter: Karl Mikaelsson <derfian>
Component: kde-workspaceAssignee: Than Ngo <than>
Status: CLOSED NOTABUG QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2   
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-02 16:25:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Karl Mikaelsson 2014-09-02 15:40:04 UTC
Description of problem:

 KDE sessions are always first in the list of sessions in GDM.

 DESKTOP_SESSION, GDMSESSION set to 1-kde-plasma-standard or 2-kde-plasma-safe rather than kde-plasma or kde-plasma-safe.

 ThinLinc can't find and start KDE :-)

Version-Release number of selected component (if applicable):

 Reproduced with kde-workspace-4.10.5-18.el7.x86_64

How reproducible:

 Happens every time.

Steps to Reproduce:

 1. install kde-workspace

Actual results:

> [root@rhel7-vmware ~]# ls -1 /usr/share/xsessions/*kde*
> /usr/share/xsessions/1-kde-plasma-standard.desktop
> /usr/share/xsessions/2-kde-plasma-safe.desktop

Expected results:

> [root@rhel7-vmware ~]# ls -1 /usr/share/xsessions/*kde*
> /usr/share/xsessions/kde-plasma.desktop
> /usr/share/xsessions/kde-plasma-safe.desktop

Additional info:

The algorithm for the order of the list of sessions presented by GDM seems to be the same as the following shell expression:

 (cd /usr/share/xsessions; ls *.desktop | sed -e 's/.desktop$//g' | sort)

Thus, having the KDE files named 1- and 2- doesn't make any real sense. Since sort is being sort and sorts kde-plasma before kde-plasma-safe, there's no real need to rename them from kde-plasma.desktop to 1-kde-plasma-standard.desktop.

Renaming the files to kde-plasma.desktop and kde-plasma-safe.desktop makes everything just peachy.

Comment 2 Than Ngo 2014-09-02 16:25:40 UTC
please take a look at the bz#1091087 why we have removed them to 1-, 2-.

I don't have ThinLinc to reproduce this issue, If ThinLinc cannot the sessions then it's a bug in ThinLinc. Thanks for your report!