Bug 1140121

Summary: RFE: QEMU: Support -name debug-threads=on
Product: [Community] Virtualization Tools Reporter: Dr. David Alan Gilbert <dgilbert>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED UPSTREAM QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: crobinso, marcandre.lureau, rbalakri
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-21 23:44:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dr. David Alan Gilbert 2014-09-10 10:36:40 UTC
Description of problem:

QEMU (somewhere around 2.0) added a new sub-option to the -name flag
   -name debug-threads=on

This causes the naming of individual QEMU threads to be helpful; e.g.
 'CPU/KVM 0' or 'migration'
these show up in top once the H key is pressed, and also show up in a core dump, making it easy to figure out which thread is which.

NOTE: The actual thread name returned by QEMU is most definitely not ABI - we could change it 3 times over a cup of coffee; it's just there to be helpful.

The reason it's not default behaviour in QEMU is worries that something somewhere might depend on the existing naming or something might treat them as ABI; if libvirt doesn't then I think it's fine for it to make a decision.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Marc-Andre Lureau 2016-03-10 12:56:48 UTC
Sent series for review upstream:
https://www.redhat.com/archives/libvir-list/2016-March/msg00388.html

Comment 2 Cole Robinson 2016-03-21 23:44:30 UTC
commit 1e34a8f91962a9a85ee6fc1478754736a5c36ff9
Author: Marc-André Lureau <marcandre.lureau@redhat.com>
Date:   Thu Mar 10 20:46:39 2016 +0100

    qemu: enable debug threads