Bug 1140158

Summary: [RFE][ToolTips] Tooltips across clickable buttons in the application provide exact same text as the button text itself
Product: Red Hat Enterprise Virtualization Manager Reporter: Gilad Lazarovich <glazarov>
Component: ovirt-engineAssignee: Greg Sheremeta <gshereme>
Status: CLOSED ERRATA QA Contact: Petr Matyáš <pmatyas>
Severity: low Docs Contact:
Priority: unspecified    
Version: 3.5.0CC: acanan, awels, bgraveno, gklein, gshereme, iheim, lsurette, rbalakri, Rhev-m-bugs, vszocs, yeylon, ykaul
Target Milestone: ovirt-3.6.0-rcKeywords: FutureFeature, Improvement
Target Release: 3.6.0Flags: sherold: Triaged+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Fixed or removed tooltips for clickable buttons that provided the exact same text as the button text.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-09 20:39:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: UX RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gilad Lazarovich 2014-09-10 11:43:35 UTC
Description of problem:
Tooltips across clickable buttons in the application provide exact same text as the button text itself

Version-Release number of selected component (if applicable):
3.5 vt2.2

How reproducible:
100%

Steps to Reproduce:
1. Navigate into any tab in the application and hover over the various clicable buttons (for example: New or Edit under the Data Centers tab)

Actual results:
The tooltip text is identical to the button text across the application

Expected results:
The tooltip should provide a more detailed text whenever possible, making user selections clearer

Comment 1 Einav Cohen 2014-09-19 16:24:20 UTC
should be an effort across all teams. 
@Vojtech/Alex/Greg: do we have an infrastructure for setting a tool-tip and a (separate) text for an action button?

Comment 2 Alexander Wels 2014-09-19 17:23:24 UTC
We do, but since we don't have any actual descriptions, the default is to set the tooltip (the title) to the text of the button if no other tool tip is provided. This happens 99% of the time, we have some icon only buttons that have some explanation text.

Comment 3 Einav Cohen 2014-09-19 21:47:40 UTC
(In reply to Alexander Wels from comment #2)
> We do, but since we don't have any actual descriptions, the default is to
> set the tooltip (the title) to the text of the button if no other tool tip
> is provided. This happens 99% of the time, we have some icon only buttons
> that have some explanation text.

thanks, Alexander.
we should probably not do that - the title of the button should probably be empty. 
if relevant - we should maybe set the 'alt' property of the button to be copied by default from the button-text value ['alt' is for text displayed instead of an object (typically an image, so not sure if applies for buttons, especially text-buttons), and 'title' is for displaying something in addition to an object, typically in a tool-tip, so no reason to duplicate the button-text to the 'title'].

Comment 4 Einav Cohen 2015-03-23 13:54:28 UTC
Greg - what is the exact status in the application with regards to tool-tips over action buttons? from what I can see, there are no tool-tips on action buttons at all, including iconized ones (i.e. 'run VM')?

Comment 5 Einav Cohen 2015-03-23 13:55:23 UTC
[clearing double needinfo]

Comment 6 Greg Sheremeta 2015-03-24 01:02:58 UTC
The buttons used to set the tooltip to the exact same text as the button title. However, for icon-only buttons, the title was hidden.

So, for icon-only buttons, this worked nicely. For everything else, tooltips == button title, which was undesirable.

I've added support to the buttons for setting a tooltip manually in the same fashion as everything else. https://gerrit.ovirt.org/#/c/39067

Comment 7 Greg Sheremeta 2015-03-24 01:04:05 UTC
... and I previously removed the automatic setting of tooltip = title that was the subject of this bug.

Should be all set now.

Comment 8 Petr Matyáš 2015-04-15 10:45:00 UTC
Now the are almost no tooltips, only on buttons with some icon in it. Which is in my opinion wrong for VMs tab - Disks subtab buttons Activate/Deactivate (same tooltip as text).
Would be nice to have some more tooltips about what a button does.

Comment 9 Greg Sheremeta 2015-04-19 12:39:58 UTC
> VMs tab - Disks subtab buttons Activate/Deactivate (same tooltip as text).

Good catch. Will fix, thanks!

> Would be nice to have some more tooltips about what a button does.

Feel free to open an RFE for the ones you think need it. It's outside of the scope of this bug.

Comment 12 errata-xmlrpc 2016-03-09 20:39:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html