Bug 1140165

Summary: Cockpit 0.21 is broken with Docker 1.2.0
Product: [Fedora] Fedora Reporter: Marius Vollmer <mvollmer>
Component: cockpitAssignee: Patrick Uiterwijk <puiterwijk>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: awilliam, puiterwijk, sgallagh, stefw
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: cockpit-0.23-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-23 02:42:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043122    

Description Marius Vollmer 2014-09-10 12:05:37 UTC
Description of problem:

Cockpit produces "Oops" when talking to Docker, such as when running an image.

Version-Release number of selected component (if applicable):

cockpit 0.21
docker-io 1.2.0

How reproducible:

Always.

Steps to Reproduce:
1. Run any Docker image with Cockpit 

Actual results:

"Oops" and a JavaScript exception.

Expected results:

"Run Image" dialog opens.

Additional info:

We missed the Docker API change, our fault.  Cockpit 0.22 fixes this.

Comment 1 Fedora Blocker Bugs Application 2014-09-10 12:16:57 UTC
Proposed as a Freeze Exception for 21-final by Fedora user sgallagh using the blocker tracking app because:

 An API change in the underlying docker.io interface broke Cockpit's ability to manage containers. As this is a major feature of Fedora 21 (and the fix is already sitting in updates-testing), we'd like permission to land this for Alpha so that it can get sufficient external exposure.

Comment 2 Fedora Update System 2014-09-10 12:55:06 UTC
cockpit-0.22-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/cockpit-0.22-1.fc21

Comment 3 Fedora Update System 2014-09-10 14:18:06 UTC
cockpit-0.23-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/cockpit-0.23-1.fc21

Comment 4 Fedora Update System 2014-09-10 16:41:14 UTC
Package cockpit-0.23-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cockpit-0.23-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10593/cockpit-0.23-1.fc21
then log in and leave karma (feedback).

Comment 5 Adam Williamson 2014-09-10 17:10:13 UTC
Discussed at 2014-09-10 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-10/f21-blocker-review.2014-09-10-16.07.log.txt . Accepted as a freeze exception issue - in theory we don't really need to break freeze for it as it's fine to get the fix through updates, but this is such a key feature of F21 we kinda want it to always work out-of-the-ISO, so accepted as a freeze exception to make sure we don't look stupid to people installing Server 'DVD' and trying it out immediately.

Comment 6 Adam Williamson 2014-09-11 03:42:50 UTC
It would be good if people could test the fix and provide karma, thanks.

Comment 7 Fedora Update System 2014-09-23 02:42:15 UTC
cockpit-0.23-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.