Bug 1145064

Summary: CUPS Web UI "Administration" Drop down does not function in Google Chrome
Product: Red Hat Enterprise Linux 6 Reporter: Clark Hale <chale>
Component: cupsAssignee: Tim Waugh <twaugh>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: low Docs Contact:
Priority: low    
Version: 6.3CC: psklenar, redhat
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: cups-1.4.2-68.el6 Doc Type: Bug Fix
Doc Text:
Due to a problem with HTTP multipart handling in the CUPS scheduler, some browsers did not work as expected when attempting to add a printer using the web interface. A change from a later version has been backported enabling adding printers in all browsers without problems.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 06:54:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Clark Hale 2014-09-22 10:17:10 UTC
Description of problem:
In the CUPS web interface, at the printer page, the "Administration" drop down does not function.

Version-Release number of selected component (if applicable):
CUPS 1.4.2
Chrome 37

How reproducible:
Every time

Steps to Reproduce:
1.  Navigate to a printer, e.g. https://localhost:631/printers/myprinter
2.  Click the "Administration" drop down
3.  Select Modify printers

Actual results:
The browser stays at the printer info page.  No action occurs. 

Expected results:
The browser goes to the modify printer page. 

Additional info:

Comment 2 Tim Waugh 2014-09-25 16:01:20 UTC
Confirmed. Here are the messages I get:

D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 13 POST /admin/ HTTP/1.1
D [25/Sep/2014:16:49:02 +0100] cupsdSetBusyState: Active clients
D [25/Sep/2014:16:49:02 +0100] cupsdAuthorize: Authorized as root using Basic
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[0] = "/usr/lib/cups/cgi-bin/admin.cgi"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[0] = "CUPS_CACHEDIR=/var/cache/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[1] = "CUPS_DATADIR=/usr/share/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[2] = "CUPS_DOCROOT=/usr/share/cups/www"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[3] = "CUPS_FONTPATH=/usr/share/cups/fonts"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[4] = "CUPS_REQUESTROOT=/var/spool/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[5] = "CUPS_SERVERBIN=/usr/lib/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[6] = "CUPS_SERVERROOT=/etc/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[7] = "CUPS_STATEDIR=/var/run/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[8] = "PATH=/usr/lib/cups/filter:/usr/lib64/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[9] = "SOFTWARE=CUPS/1.4.2"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[10] = "USER=root"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[11] = "CUPS_SERVER=/var/run/cups/cups.sock"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[12] = "CUPS_ENCRYPTION=IfRequested"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[13] = "IPP_PORT=631"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[14] = "AUTH_TYPE=Basic"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[15] = "LANG=en_GB.UTF8"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[16] = "REDIRECT_STATUS=1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[17] = "GATEWAY_INTERFACE=CGI/1.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[18] = "SERVER_NAME=192.168.122.176"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[19] = "SERVER_PORT=631"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[20] = "REMOTE_ADDR=192.168.122.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[21] = "REMOTE_HOST=192.168.122.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[22] = "SCRIPT_NAME=/admin/"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[23] = "SCRIPT_FILENAME=/usr/share/cups/www/admin/"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[24] = "REMOTE_USER=root"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[25] = "SERVER_PROTOCOL=HTTP/1.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[26] = "HTTP_COOKIE=org.cups.sid=03db6776b45128bdb8ce534f06c5933d"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[27] = "HTTP_USER_AGENT=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[28] = "HTTP_REFERER=https://192.168.122.176:631/printers/test"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[29] = "REQUEST_METHOD=POST"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[30] = "CONTENT_LENGTH=81"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[31] = "CONTENT_TYPE=application/x-www-form-urlencoded"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[32] = "HTTPS=ON"
D [25/Sep/2014:16:49:02 +0100] [CGI] Started /usr/lib/cups/cgi-bin/admin.cgi (PID 3570)
I [25/Sep/2014:16:49:02 +0100] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3570)
D [25/Sep/2014:16:49:02 +0100] cupsdSendCommand: 13 file=16
D [25/Sep/2014:16:49:02 +0100] [CGI] admin.cgi started...
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: skipping getpeercon()
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: 15 from localhost (Domain)
D [25/Sep/2014:16:49:02 +0100] [CGI] http=0x7f2741053880
D [25/Sep/2014:16:49:02 +0100] [CGI] org.cups.sid cookie is "03db6776b45128bdb8ce534f06c5933d"
D [25/Sep/2014:16:49:02 +0100] [CGI] op="modify-printer"...
D [25/Sep/2014:16:49:02 +0100] [CGI] do_am_printer: DEVICE_URI="(null)"
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 POST / HTTP/1.1
D [25/Sep/2014:16:49:02 +0100] cupsdAuthorize: No authentication data provided.
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 1.1 Get-Printer-Attributes 1
D [25/Sep/2014:16:49:02 +0100] Get-Printer-Attributes ipp://localhost/printers/test
D [25/Sep/2014:16:49:02 +0100] Returning IPP successful-ok for Get-Printer-Attributes (ipp://localhost/printers/test) from localhost
D [25/Sep/2014:16:49:02 +0100] [CGI] Getting list of devices...
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 POST / HTTP/1.1
D [25/Sep/2014:16:49:02 +0100] cupsdAuthorize: No authentication data provided.
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 1.1 CUPS-Get-Devices 1
D [25/Sep/2014:16:49:02 +0100] CUPS-Get-Devices
D [25/Sep/2014:16:49:02 +0100] cupsdIsAuthorized: username=""
D [25/Sep/2014:16:49:02 +0100] Returning HTTP Unauthorized for CUPS-Get-Devices (no URI) from localhost
D [25/Sep/2014:16:49:02 +0100] cupsdSendHeader: 15 WWW-Authenticate: Basic realm="CUPS"
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 WAITING Closing on EOF
D [25/Sep/2014:16:49:02 +0100] cupsdCloseClient: 15
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: skipping getpeercon()
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: 15 from localhost (Domain)
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 WAITING Closing on EOF
D [25/Sep/2014:16:49:02 +0100] cupsdCloseClient: 15
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: skipping getpeercon()
D [25/Sep/2014:16:49:02 +0100] cupsdAcceptClient: 15 from localhost (Domain)
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 POST / HTTP/1.1
D [25/Sep/2014:16:49:02 +0100] cupsdAuthorize: Authorized as root using Local
D [25/Sep/2014:16:49:02 +0100] cupsdReadClient: 15 1.1 CUPS-Get-Devices 1
D [25/Sep/2014:16:49:02 +0100] CUPS-Get-Devices
D [25/Sep/2014:16:49:02 +0100] cupsdIsAuthorized: username="root"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[0] = "/usr/lib/cups/daemon/cups-deviced"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[1] = "1"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[2] = "0"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[3] = "30"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[4] = "4"
D [25/Sep/2014:16:49:02 +0100] [CGI] argv[5] = "requested-attributes=all"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[0] = "CUPS_CACHEDIR=/var/cache/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[1] = "CUPS_DATADIR=/usr/share/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[2] = "CUPS_DOCROOT=/usr/share/cups/www"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[3] = "CUPS_FONTPATH=/usr/share/cups/fonts"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[4] = "CUPS_REQUESTROOT=/var/spool/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[5] = "CUPS_SERVERBIN=/usr/lib/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[6] = "CUPS_SERVERROOT=/etc/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[7] = "CUPS_STATEDIR=/var/run/cups"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[8] = "PATH=/usr/lib/cups/filter:/usr/lib64/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[9] = "SOFTWARE=CUPS/1.4.2"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[10] = "USER=root"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[11] = "CUPS_SERVER=/var/run/cups/cups.sock"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[12] = "CUPS_ENCRYPTION=IfRequested"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[13] = "IPP_PORT=631"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[14] = "AUTH_TYPE=Local"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[15] = "LANG=en_GB.UTF8"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[16] = "REDIRECT_STATUS=1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[17] = "GATEWAY_INTERFACE=CGI/1.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[18] = "SERVER_NAME=localhost"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[19] = "SERVER_PORT=631"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[20] = "REMOTE_ADDR="
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[21] = "REMOTE_HOST=localhost"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[22] = "SCRIPT_NAME=/"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[23] = "SCRIPT_FILENAME=/usr/share/cups/www/"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[24] = "REMOTE_USER=root"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[25] = "SERVER_PROTOCOL=HTTP/1.1"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[26] = "HTTP_USER_AGENT=CUPS/1.4.2"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[27] = "REQUEST_METHOD=POST"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[28] = "CONTENT_LENGTH=91"
D [25/Sep/2014:16:49:02 +0100] [CGI] envp[29] = "CONTENT_TYPE=application/ipp"
D [25/Sep/2014:16:49:02 +0100] [CGI] Started /usr/lib/cups/daemon/cups-deviced (PID 3571)
I [25/Sep/2014:16:49:02 +0100] Started "/usr/lib/cups/daemon/cups-deviced" (pid=3571)
D [25/Sep/2014:16:49:02 +0100] cupsdSendCommand: 15 file=17
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/snmp (PID 3572)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/usb (PID 3573)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/dnssd (PID 3574)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/https (PID 3575)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/mdns (PID 3576)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/lpd (PID 3577)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/ncp (PID 3578)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/beh (PID 3579)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/scsi (PID 3580)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/http (PID 3581)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/ipp (PID 3582)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/serial (PID 3583)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/socket (PID 3584)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/smb (PID 3585)
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Started backend /usr/lib/cups/backend/parallel (PID 3587)
D [25/Sep/2014:16:49:02 +0100] Script header: Content-Type: application/ipp
D [25/Sep/2014:16:49:02 +0100] Script header: 
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "https"...
D [25/Sep/2014:16:49:02 +0100] [CGI] lang="en_GB.UTF8", locale="/en_GB"...
D [25/Sep/2014:16:49:02 +0100] Script header: MIME-Version: 1.0
D [25/Sep/2014:16:49:02 +0100] Script header: Content-Type: multipart/x-mixed-replace; boundary="CUPS-MULTIPART"
D [25/Sep/2014:16:49:02 +0100] Script header: 
D [25/Sep/2014:16:49:02 +0100] [CGI] lang="en_GB.UTF8", locale="/en_GB"...
D [25/Sep/2014:16:49:02 +0100] [CGI] Regular expression "[a-z]+://"
D [25/Sep/2014:16:49:02 +0100] [CGI] Regular expression "[a-z]+://"
D [25/Sep/2014:16:49:02 +0100] [CGI] lang="en_GB.UTF8", locale="/en_GB"...
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "lpd"...
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "scsi"...
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "http"...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3573 (usb) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3575 (https) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3576 (mdns) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3577 (lpd) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3578 (ncp) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3580 (scsi) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3581 (http) exited with no errors.
E [25/Sep/2014:16:49:02 +0100] [CGI] Unable to create avahi client: Resource temporarily unavailable
E [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3574 (dnssd) stopped with status 1!
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "beh"...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3579 (beh) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "ipp"...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3587 (parallel) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "socket"...
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "smb"...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3582 (ipp) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3584 (socket) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [CGI] Flushed attributes...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] Found device "serial:/dev/ttyS0?baud=115200"...
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3585 (smb) exited with no errors.
D [25/Sep/2014:16:49:02 +0100] [cups-deviced] PID 3583 (serial) exited with no errors.
D [25/Sep/2014:16:49:04 +0100] [cups-deviced] PID 3572 (snmp) exited with no errors.
D [25/Sep/2014:16:49:04 +0100] PID 3571 (/usr/lib/cups/daemon/cups-deviced) exited with no errors.
D [25/Sep/2014:16:49:04 +0100] [CGI] Got device list!
D [25/Sep/2014:16:49:04 +0100] [CGI] lang="en_GB.UTF8", locale="/en_GB"...
D [25/Sep/2014:16:49:04 +0100] cupsdWriteClient: 13 Closing for error 0 (Success)
D [25/Sep/2014:16:49:04 +0100] cupsdCloseClient: 13
E [25/Sep/2014:16:49:04 +0100] SSL shutdown failed: Error in the push function.
D [25/Sep/2014:16:49:04 +0100] cupsdSetBusyState: Not busy
D [25/Sep/2014:16:49:04 +0100] cupsdReadClient: 13 Closing on EOF
D [25/Sep/2014:16:49:04 +0100] cupsdCloseClient: 13
D [25/Sep/2014:16:49:04 +0100] [CGI] lang="en_GB.UTF8", locale="/en_GB"...
D [25/Sep/2014:16:49:04 +0100] cupsdReadClient: 15 WAITING Closing on EOF
D [25/Sep/2014:16:49:04 +0100] cupsdCloseClient: 15
D [25/Sep/2014:16:49:04 +0100] PID 3570 (/usr/lib/cups/cgi-bin/admin.cgi) was terminated normally with signal 9.

...which looks like Chrome decided to close the connection early.

16:51:50.829771 IP 192.168.122.1.34461 > 192.168.122.176.ipp: Flags [P.], seq 795267187:795267960, ack 1516424901, win 1021, options [nop,nop,TS val 6026544 ecr 1064093], length 773
16:51:50.869024 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [.], ack 773, win 370, options [nop,nop,TS val 1070054 ecr 6026544], length 0
16:51:50.963839 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 1:342, ack 773, win 370, options [nop,nop,TS val 1070148 ecr 6026544], length 341
16:51:50.963922 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 342:603, ack 773, win 370, options [nop,nop,TS val 1070148 ecr 6026544], length 261
16:51:50.964033 IP 192.168.122.1.34461 > 192.168.122.176.ipp: Flags [.], ack 603, win 1043, options [nop,nop,TS val 6026678 ecr 1070148], length 0
16:51:50.964049 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [.], seq 603:2051, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026544], length 1448
16:51:50.964060 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 2051:2624, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026544], length 573
16:51:50.964124 IP 192.168.122.1.34461 > 192.168.122.176.ipp: Flags [.], ack 2624, win 1089, options [nop,nop,TS val 6026679 ecr 1070149], length 0
16:51:50.964131 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 2624:2853, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026678], length 229
16:51:50.964245 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 2853:2906, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026679], length 53
16:51:50.964291 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 2906:3631, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026679], length 725
16:51:50.964340 IP 192.168.122.176.ipp > 192.168.122.1.34461: Flags [P.], seq 3631:3732, ack 773, win 370, options [nop,nop,TS val 1070149 ecr 6026679], length 101
16:51:50.964874 IP 192.168.122.1.34461 > 192.168.122.176.ipp: Flags [R.], seq 773, ack 3732, win 1134, options [nop,nop,TS val 6026679 ecr 1070149], length 0

Chrome's console says "Resource interpreted as Document but transferred with MIME type multipart/x-mixed-replace: "https://192.168.122.176:631/admin/".

Not sure what's going wrong.

Comment 3 Richard van der Hoff 2014-11-08 18:53:45 UTC
I came across this problem too.

It turns out that, until CUPS v1.4.7, CUPS used a feature called 'multipart/x-mixed-replace' to display the first 'Modify printer' page. In CUPS v1.4.7, they decided it was too buggy to support [1].

Support for this feature was removed in Chrome 29 [2].

The workaround I used was to use the useragent switcher [1] to set a useragent of 'Opera'. This stops CUPS trying to use multipart/x-mixed-replace.


[1] http://cups.org/str.php?L3455.

[2] https://code.google.com/p/chromium/issues/detail?id=249132

[3] https://chrome.google.com/webstore/detail/user-agent-switcher/ffhkkpnppgnfaobgihpdblnhmmbodake?hl=en

Comment 4 Tim Waugh 2014-11-10 17:46:07 UTC
OK, even clicking 'Add printer' on the admin page fails. The patch from STR #3455 fixes that.

How to reproduce it:
service iptables stop
cupsctl --remote-admin
lpadmin -p test -v /dev/null -E

In Chrome on any machine, navigate to https://rhel6host:631/printers/test
Proceed even though the certificate is not signed by a CA (it's self-signed)
Click the Administration drop-down and select Modify

Another test:
In Chrome on any machine, navigate to https://rhel6host:631/admin
Click Add Printer

Comment 8 errata-xmlrpc 2015-07-22 06:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1346.html