Bug 11464

Summary: kernel compiled for 2GB RAM won't run executables over 400Mb
Product: [Retired] Red Hat Linux Reporter: wpk20
Component: kernelAssignee: Jakub Jelinek <jakub>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-08 21:33:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 11928    

Description wpk20 2000-05-17 10:00:56 UTC
default kernel for machine uses 1Gb system RAM. this kernel will happily
run executables up to around 1Gb size, as you might expect. these
executables are from fortran77 source, on f77 compiler or pgf77 compiler.

however with a kernel compiled for 2Gb RAM in xconfig, linux runs OK and
recognises that it has 2GB system RAM but will only run executables of up
to around 400Mb. this isn't a fortran problem, all programs have the same
error, and i've checked the code and debug reports with xxgdb.

Comment 1 Doug Ledford 2000-05-22 18:43:59 UTC
Please update to the latest kernel release.  The 400MB application size limit is
partly due to library mapping locations and other similar fixed address
allocations.  The latest Red Hat kernels include the 4GB BIGMEM patch so that
they can access 4GB of RAM *and* still provide a 3-1 split of virtual address to
kernel mapped memory space.  This should solve your problem.  The issue you are
reporting isn't actually a bug, it's a side effect of the 2-2 split option in
the kernel.

Comment 2 wpk20 2000-06-23 13:25:15 UTC
bigmem patch in 2.2.12-5.0 seems to not solve this problem. compiles & boots OK, 
same memory error.

Comment 3 wpk20 2000-07-17 10:40:26 UTC
bigmem patch in 2.2.14-12 still not solving problem.  machine memory recognised
OK, memory split only slightly improved (can now run up to about 600Mb).

Comment 4 Alan Cox 2000-08-08 21:32:36 UTC
C library issue


Comment 5 wpk20 2000-08-09 08:38:00 UTC
in kernel 2.4.0-test4, with HIGHMEM support enabled, the problem solved by
adjusting the TASK_UNMAPPED_BASE definition line in processor.h. normally
defined as 'TASK_SIZE/3', i set to 'TASK_SIZE/1.5'. i would expect HIGHMEM patch
to do this anyway though, patch doesn't solve problem without this fix. (fix
discussed with ingo molnar mingo@redhat.com).