Bug 1147304

Summary: Project search fails on special characters
Product: [Retired] Zanata Reporter: Damian Jansen <djansen>
Component: Component-LogicAssignee: Alex Eng <aeng>
Status: CLOSED CURRENTRELEASE QA Contact: Damian Jansen <djansen>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.5CC: dchen, mkim, zanata-bugs
Target Milestone: ---   
Target Release: 3.7   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3693) Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 02:19:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of error
none
redhat-menus project search not returning the correct result. none

Description Damian Jansen 2014-09-29 00:53:49 UTC
Created attachment 942094 [details]
Screenshot of error

Description of problem:
If the user creates a project with a name using special characters, such as "[RHEL] My Project", searching for "[RHEL]" will not show that project.

Version-Release number of selected component (if applicable):
3.5.0-SNAPSHOT (git-server-3.4.2-297-g18385b6)

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in, got to Projects, create new project
2. Enter a valid id, and a name of [project]my project, press save
3. Enter [project] into the top project search bar

Actual results:
No projects displayed

Expected results:
The [project]my project should be listed

Additional info:

Comment 2 Michelle Kim 2014-10-01 04:21:15 UTC
Created attachment 942912 [details]
redhat-menus project search not returning the correct result.

Comment 3 Michelle Kim 2014-10-01 04:26:18 UTC
I just find out that there is already a bug for the project search fails and it seems it is already verified and will go to 3.5 

release.https://bugzilla.redhat.com/show_bug.cgi?id=1102455

Would the 1102455 bug also fix this special character bug as well?

Comment 4 Ding-Yi Chen 2014-10-01 04:31:35 UTC
It can still reproduced in Zanata 3.5.0-SNAPSHOT (git-jenkins-zanata-server-build+verify-nightly-release-1167-299-ga85e7f8)

Comment 5 Alex Eng 2015-06-01 04:11:28 UTC
Pull request:

https://github.com/zanata/zanata-server/pull/839

Comment 6 Damian Jansen 2015-06-02 05:11:08 UTC
Verified at 1b2c207a1c0ec9eea604a00311c665cb36ae3a12