Bug 1147822

Summary: DNF Fails to synchronize cache for local repo
Product: [Fedora] Fedora Reporter: Sudhir Khanger <sudhir>
Component: dnfAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: jsilhan, jzeleny, packaging-team-maint, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-03 16:54:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sudhir Khanger 2014-09-30 07:01:54 UTC
Description of problem: I have a local repo created by yum-plugin-local/createrepo which can't be read/processed by DNF. It gives the following error.

Failed to synchronize cache for repo '_local' from '[u'file:/home/$USER/Documents/Software/local']': Cannot prepare internal mirrorlist: realpath(file:/home/$USER/Documents/Software/local) error: No such file or directory, disabling.


Version-Release number of selected component (if applicable): dnf-0.5.4-2.fc20.noarch


How reproducible: Always


Steps to Reproduce:
1.Setup a local repo either using yum-plugin-local or createrepo --database ~/_local_repo
2. dnf <command>
3.

Actual results: Fails and disabled the local repo.

Expected results: Should process the local repo just like any other repo


Additional info:

Comment 1 Honza Silhan 2014-10-03 16:50:29 UTC
Hi, thanks for the report we'll take a look.

Comment 2 Honza Silhan 2014-10-03 16:54:42 UTC

*** This bug has been marked as a duplicate of bug 991014 ***