Bug 1147978

Summary: Can not create jenkins slave
Product: [Fedora] Fedora Reporter: Amita Sharma <amsharma>
Component: jenkinsAssignee: Michal Srb <msrb>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: java-sig-commits, msrb
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: jenkins-remoting-2.46-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-01 17:02:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Amita Sharma 2014-09-30 13:07:24 UTC
Description of problem:
Can not create jenkins slave

Version-Release number of selected component (if applicable):

[root@dhcp201-185 ~]# rpm -qa | grep jenkins
jenkins-icon-shim-1.0.3-1.fc21.noarch
js-yui2-jenkins-2.9.0-6.fc21.noarch
jenkins-task-reactor-1.4-2.fc21.noarch
jenkins-external-monitor-job-plugin-1.2-1.fc21.noarch
jenkins-javadoc-plugin-1.2-1.fc21.noarch
jenkins-commons-jelly-1.1.20120928-6.fc21.noarch
jenkins-instance-identity-1.3-4.fc21.noarch
jenkins-sshd-1.6-4.fc21.noarch
jenkins-1.581-2.fc21.noarch
jenkins-ant-plugin-1.2-1.fc21.noarch
jenkins-executable-war-1.29-3.fc21.noarch
jenkins-xstream-1.4.7-3.jenkins1.fc21.noarch
trilead-ssh2-217-4.jenkins4.fc21.noarch
jenkins-ssh-cli-auth-1.2-4.fc21.noarch
jenkins-core-1.581-2.fc21.noarch
jenkins-remoting-2.43-1.fc21.noarch
jenkins-json-lib-2.4-7.fc21.noarch
jenkins-junit-plugin-1.1-1.fc21.noarch
jenkins-mailer-plugin-1.11-1.fc21.noarch
jenkins-extras-memory-monitor-1.8-1.fc21.noarch
jenkins-crypto-util-1.4-2.fc21.noarch
jenkins-version-number-1.1-4.fc21.noarch
jenkins-webapp-1.581-2.fc21.noarch
jenkins-winstone-2.3-1.fc21.noarch
jenkins-jexl-1.1-3.20111212.fc21.noarch
jenkins-cli-1.581-2.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. Execute steps from https://fedoraproject.org/wiki/Msrb:TestDay/Test_8


Actual results:
This node is offline because Jenkins failed to launch the slave agent on it.

Expected results:
Slave should be up and running in jenkins

Additional info:
Logs ::
[09/30/14 18:38:38] [SSH] Starting sftp client.
[09/30/14 18:38:38] [SSH] Copying latest slave.jar...
hudson.util.IOException2: Could not copy slave.jar into '/tmp/jenkins' on slave
	at hudson.plugins.sshslaves.SSHLauncher.copySlaveJar(SSHLauncher.java:1075)
	at hudson.plugins.sshslaves.SSHLauncher.access$300(SSHLauncher.java:133)
	at hudson.plugins.sshslaves.SSHLauncher$2.call(SSHLauncher.java:703)
	at hudson.plugins.sshslaves.SSHLauncher$2.call(SSHLauncher.java:690)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: hudson.util.IOException2: Could not copy slave.jar to '/tmp/jenkins/slave.jar' on slave
	at hudson.plugins.sshslaves.SSHLauncher.copySlaveJar(SSHLauncher.java:1072)
	... 7 more
Caused by: java.io.FileNotFoundException: /target/jenkins/WEB-INF/slave.jar (No such file or directory)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:138)
	at java.io.FileInputStream.<init>(FileInputStream.java:93)
	at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:90)
	at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:188)
	at hudson.model.Slave$JnlpJar.readFully(Slave.java:334)
	at hudson.plugins.sshslaves.SSHLauncher.copySlaveJar(SSHLauncher.java:1063)
	... 7 more
[09/30/14 18:38:38] Launch failed - cleaning up connection
[09/30/14 18:38:38] [SSH] Connection closed.

Comment 1 Fedora Update System 2014-10-14 10:29:37 UTC
jenkins-remoting-2.46-2.fc21,jenkins-ant-plugin-1.2-2.fc21,jenkins-credentials-plugin-1.10-5.fc21,jenkins-external-monitor-job-plugin-1.2-2.fc21,jenkins-javadoc-plugin-1.2-2.fc21,jenkins-junit-plugin-1.1-2.fc21,jenkins-mailer-plugin-1.11-2.fc21,jenkins-ssh-credentials-plugin-1.6.1-4.fc21,jenkins-ssh-slaves-plugin-1.6-4.fc21,js-yui2-2.9.0-7.fc21,js-CodeMirror-4.0.3-4.fc21,jenkins-1.581-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/jenkins-remoting-2.46-2.fc21,jenkins-ant-plugin-1.2-2.fc21,jenkins-credentials-plugin-1.10-5.fc21,jenkins-external-monitor-job-plugin-1.2-2.fc21,jenkins-javadoc-plugin-1.2-2.fc21,jenkins-junit-plugin-1.1-2.fc21,jenkins-mailer-plugin-1.11-2.fc21,jenkins-ssh-credentials-plugin-1.6.1-4.fc21,jenkins-ssh-slaves-plugin-1.6-4.fc21,js-yui2-2.9.0-7.fc21,js-CodeMirror-4.0.3-4.fc21,jenkins-1.581-3.fc21

Comment 2 Fedora Update System 2014-10-16 02:06:45 UTC
Package jenkins-remoting-2.46-2.fc21, jenkins-ant-plugin-1.2-2.fc21, jenkins-credentials-plugin-1.10-5.fc21, jenkins-external-monitor-job-plugin-1.2-2.fc21, jenkins-javadoc-plugin-1.2-2.fc21, jenkins-junit-plugin-1.1-2.fc21, jenkins-mailer-plugin-1.11-2.fc21, jenkins-ssh-credentials-plugin-1.6.1-4.fc21, jenkins-ssh-slaves-plugin-1.6-4.fc21, js-yui2-2.9.0-7.fc21, js-CodeMirror-4.0.3-4.fc21, jenkins-1.581-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jenkins-remoting-2.46-2.fc21 jenkins-ant-plugin-1.2-2.fc21 jenkins-credentials-plugin-1.10-5.fc21 jenkins-external-monitor-job-plugin-1.2-2.fc21 jenkins-javadoc-plugin-1.2-2.fc21 jenkins-junit-plugin-1.1-2.fc21 jenkins-mailer-plugin-1.11-2.fc21 jenkins-ssh-credentials-plugin-1.6.1-4.fc21 jenkins-ssh-slaves-plugin-1.6-4.fc21 js-yui2-2.9.0-7.fc21 js-CodeMirror-4.0.3-4.fc21 jenkins-1.581-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12898/jenkins-remoting-2.46-2.fc21,jenkins-ant-plugin-1.2-2.fc21,jenkins-credentials-plugin-1.10-5.fc21,jenkins-external-monitor-job-plugin-1.2-2.fc21,jenkins-javadoc-plugin-1.2-2.fc21,jenkins-junit-plugin-1.1-2.fc21,jenkins-mailer-plugin-1.11-2.fc21,jenkins-ssh-credentials-plugin-1.6.1-4.fc21,jenkins-ssh-slaves-plugin-1.6-4.fc21,js-yui2-2.9.0-7.fc21,js-CodeMirror-4.0.3-4.fc21,jenkins-1.581-3.fc21
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-11-01 17:02:33 UTC
jenkins-remoting-2.46-2.fc21, jenkins-ant-plugin-1.2-2.fc21, jenkins-credentials-plugin-1.10-5.fc21, jenkins-external-monitor-job-plugin-1.2-2.fc21, jenkins-javadoc-plugin-1.2-2.fc21, jenkins-junit-plugin-1.1-2.fc21, jenkins-mailer-plugin-1.11-2.fc21, jenkins-ssh-credentials-plugin-1.6.1-4.fc21, jenkins-ssh-slaves-plugin-1.6-4.fc21, js-yui2-2.9.0-7.fc21, js-CodeMirror-4.0.3-4.fc21, jenkins-1.581-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.