Bug 1149889

Summary: RFE: download command in copr-cli
Product: [Community] Copr Reporter: Honza Horak <hhorak>
Component: cliAssignee: Valentin Gologuzov <vgologuz>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: jberan, msuchy, vgologuz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: copr-cli-1.39-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-22 15:14:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Honza Horak 2014-10-06 20:25:24 UTC
Description of problem:

copr-cli misses a command similar to koji's download-build. It would download resulted RPMs for specified copr and it could also have similar options like --arch, even if copr currently does not support more architectures.

Comment 1 Valentin Gologuzov 2014-10-16 09:40:23 UTC
Added command "download-build" in commit 622db5bc97e56db91d397085e4d80dc96a56299f
A bit dirty solution, since api doesn't provide direct links to rpms, so cli uses prior knowledge of file structure on server + wget recursive download.