Bug 1150730

Summary: Need a demo repo for puppet content
Product: [Retired] Pulp Reporter: Brian Bouterse <bmbouter>
Component: z_otherAssignee: pulp-bugs
Status: CLOSED UPSTREAM QA Contact: pulp-qe-list
Severity: medium Docs Contact:
Priority: low    
Version: MasterCC: cduryee, mhrivnak
Target Milestone: ---Keywords: Task, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-28 22:39:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Bouterse 2014-10-08 20:06:34 UTC
Recently I needed to do some testing with puppet content, and it was hard. Puppet forge sync's can't be published because duplicate names. Also some of the content could be corrupt and unpredictable in other ways. It may be useful to have a repo like 'zoo' only for puppet content.

It would also be good if these fake puppet modules contained symlinks as puppet content can have.

This would also be valuable for testing, and could be added to the docs for a more consistent (and quicker) demo of puppet functionality than puppetforge.

Comment 1 Brian Bouterse 2015-02-28 22:39:00 UTC
Moved to https://pulp.plan.io/issues/572