Bug 1151559

Summary: User interface freezes when entering space character in Xfig
Product: Red Hat Enterprise Linux 6 Reporter: Marc-Andre Lureau <marcandre.lureau>
Component: xorg-x11-drv-qxlAssignee: Marc-Andre Lureau <marcandre.lureau>
Status: CLOSED ERRATA QA Contact: SPICE QE bug list <spice-qe-bugs>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.6CC: agajania, alexl, alon, astepano, cfergeau, dblechte, extras-qa, hdegoede, jforbes, kraxel, marcandre.lureau, mkenneth, rbalakri, rpacheco, sandmann, tpelka, uril, virt-bugs, virt-maint, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xorg-x11-drv-qxl-0.1.1-16.el6 Doc Type: Bug Fix
Doc Text:
Cause: bug in the way the qxl driver handles unexpected drawing commands Consequence: the display would freeze when entering a space character in the Xfig application Fix: Make sure the QXL driver does not misbehave when such a situation occurs Result: no more display freeze
Story Points: ---
Clone Of: 1151363
: 1221909 (view as bug list) Environment:
Last Closed: 2015-07-22 07:31:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1151363    
Bug Blocks: 1221909    

Description Marc-Andre Lureau 2014-10-10 17:12:55 UTC
+++ This bug was initially created as a clone of Bug #1151363 +++

--- Additional comment from Alon Levy on 2014-10-10 11:38:55 EDT ---

You can change the qemu condition to be nicer to old drivers, and (to avoid requiring upgrades of qemu) fix the driver not to do an update area in this case.

Comment 2 Marc-Andre Lureau 2014-10-12 13:24:44 UTC
sent patches:
http://lists.freedesktop.org/archives/spice-devel/2014-October/017598.html

Comment 6 errata-xmlrpc 2015-07-22 07:31:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1399.html