Bug 1156519

Summary: PySSL segmentation fault
Product: [Fedora] Fedora Reporter: Martin Bašti <mbasti>
Component: pythonAssignee: Robert Kuska <rkuska>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: bkabrda, dmalcolm, ivazqueznet, jberan, jonathansteffan, mstuchli, ncoghlan, rkuska, tomspur, tradej
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-2.7.8-5.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-01 17:15:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Bašti 2014-10-24 15:41:12 UTC
Description of problem:
PySSL extension segmentation fault

Version-Release number of selected component (if applicable):
python-2.7.8-4.1.fc21.x86_64


How reproducible:
https://fedorahosted.org/freeipa/ticket/4649

Steps to Reproduce:
1.
2.
3.

Actual results:
Segmentation fault

Expected results:
No segmentation fault

Additional info:
http://bugs.python.org/issue22717

Comment 1 Robert Kuska 2014-10-27 15:43:57 UTC
I have disabled the patch which introduced this bug since it is no long needed, new python build is on its way.

Comment 2 Fedora Update System 2014-10-29 07:09:58 UTC
python-2.7.8-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-2.7.8-5.fc21

Comment 3 Fedora Update System 2014-10-31 01:24:43 UTC
Package python-2.7.8-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-2.7.8-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13897/python-2.7.8-5.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-11-01 17:15:20 UTC
python-2.7.8-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.