This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 115975

Summary: sshd failed once after reboot (update of several packages)
Product: [Fedora] Fedora Reporter: shrek-m <shrek-m>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-07 10:14:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description shrek-m 2004-02-17 07:51:55 EST
Description of problem:
--------
# rpm -qa openssh* freeradius kernel* | sort
freeradius-0.9.3-1.1
kernel-2.4.22-1.2149.nptl
kernel-2.4.22-1.2166.nptl
kernel-pcmcia-cs-3.1.31-13
kernel-source-2.4.22-1.2149.nptl
kernel-source-2.4.22-1.2166.nptl
kernel-utils-2.4-9.1.101.fedora
openssh-3.6.1p2-19
openssh-askpass-3.6.1p2-19
openssh-askpass-gnome-3.6.1p2-19
openssh-clients-3.6.1p2-19
openssh-server-3.6.1p2-19


# rhn-applet-tui
Ignoring
No package updates are needed.
--------

after updating the packages ..., see "additional information"

sshd failed once after reboot [ failed ]
error (not really sure):   PRNG

# service sshd restart [ ok ]

reboot -> [ ok ]

this happend luckily on my fc1 machine @home
because i have a few servers (actually rhl 7.3, asap rheles3) with
ssh-remote-access this would not be the expected behavior :-(

Version-Release number of selected component (if applicable):
openssh-server-3.6.1p2-19

How reproducible:
Sometimes

Steps to Reproduce:
1. update of several packages
2. reboot
    

Actual Results:  sshd failed, no access via ssh

Expected Results:  sshd should be started

Additional info:

# zgrep "sshd" /var/log/messages* | grep fail
/var/log/messages:Feb 17 12:52:30 xp1800 sshd:  failed
/var/log/messages.1:Feb 11 19:35:36 xp1800 sshd:  failed

# zgrep "ssh" /var/log/boot.log* | grep fail
/var/log/boot.log:Feb 17 12:52:30 xp1800 sshd:  failed
/var/log/boot.log.1:Feb 11 19:35:36 xp1800 sshd:  failed


####<updates>####
# head -15 /changelog.txt
----
20040217 12:00 WeM
updates i386 samba-*, redhat-config-printer*, rdesktop, mutt, gaim,
freeradius, XFree86*
 
----
20040211 19:30 WeM
updates athlon kernel 2.4.*66; i386 kernel-source
beobachten, evtl download-problem, da ueber mozilla
keine fehlermeldung beim installieren  -ivh
 
i386 [foomatic,hpijs] ghostscript, gimp-print*
 
----
20040210 23:00 WeM
####</updates>#####
Comment 1 shrek-m 2004-02-27 04:28:05 EST
happened again :-(

i had not recognized it 20040226
but while the next boot 20040227
solved with `service ssh start`
afterwards it is ok while booting.


# zgrep ssh /var/log/messages* | grep failed
/var/log/messages:Feb 26 18:20:09 xp1800 sshd:  failed
/var/log/messages:Feb 27 08:45:31 xp1800 sshd:  failed
/var/log/messages.1:Feb 17 12:52:30 xp1800 sshd:  failed
/var/log/messages.2:Feb 11 19:35:36 xp1800 sshd:  failed


installaed packages before sshd failed while booting
----
20040226 08:45 WeM
testing perl-5.8.3-10 mod-perl-1.99_12-2
----
Comment 2 shrek-m 2004-02-28 04:16:07 EST
happened today 2 times,
the error is    "PRNG is not seeded"
after the 3. reboot it went away without changes.

--------
google eg.:
http://www.linuxquestions.org/questions/archive/14/2003/12/4/129666
http://www.linux.com/howtos/Apache-WebDAV-LDAP-HOWTO/ssl.shtml
"PRNG not seeded"	
If you do not have /dev/random on your system you will get a "PRNG not
seeded" error message.
In that case you can use the following command:
# /usr/local/ssl/bin/openssl req -rand some_file.ext -new -nodes
-keyout private.key -out public.csr 
--------


$ ls /etc/rc3.d/S20* /etc/rc3.d/*ssh*
/etc/rc3.d/S20apcupsd  /etc/rc3.d/S20random  /etc/rc3.d/S55sshd

apcupsd is installed since october 2003


# grep "random\|apc\|ssh" /var/log/messages | less
Feb 28 09:11:04 xp1800 apcupsd: Starten von apcupsd succeeded
Feb 28 09:11:04 xp1800 random: Zufallszahlenerzeuger initialisieren: 
succeeded
Feb 28 09:11:12 xp1800 sshd:
Feb 28 09:11:12 xp1800 sshd:  failed
Feb 28 09:11:25 xp1800 apcupsd[1206]: NIS server startup succeeded
Feb 28 09:11:25 xp1800 apcupsd[1206]: apcupsd 3.10.6 (28 October 2003)
redhat startup succeeded
Feb 28 09:15:12 xp1800 random: Zufallsstartwert speichern:  succeeded
Feb 28 09:16:50 xp1800 apcupsd: Starten von apcupsd succeeded
Feb 28 09:16:50 xp1800 random: Zufallszahlenerzeuger initialisieren: 
succeeded
Feb 28 09:16:59 xp1800 sshd:
Feb 28 09:16:59 xp1800 sshd:  failed
Feb 28 09:17:11 xp1800 apcupsd[1206]: NIS server startup succeeded
Feb 28 09:17:11 xp1800 apcupsd[1206]: apcupsd 3.10.6 (28 October 2003)
redhat startup succeeded


i will try to start apcupsd after random.
Comment 3 Tomas Mraz 2005-02-07 10:01:26 EST
Does it happen for you with the current Fedora Core? (FC3)
Comment 4 shrek-m 2005-02-07 10:14:15 EST
no problems since 20041110
clean fresh install fc3 and apcupsd

# grep -1 neuinstallation  /changelog.txt
20041110 13:00 ShM
neuinstallation FC3, alle pakete, ca 1 std
incl. alle bisherigen updates