Bug 1160636

Summary: lasso / mod_auth_mellon Microsoft ADFS interoperability patches.
Product: Red Hat Enterprise Linux 6 Reporter: Jarek Polok <jaroslaw.polok>
Component: lassoAssignee: Simo Sorce <ssorce>
Status: CLOSED ERRATA QA Contact: Namita Soman <nsoman>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.6CC: csutherl, dpal, mkosek, mschuppe, tdbrody
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Users of the lasso packages could previously experience several problems related to Red Hat Enterprise Linux interoperability with Microsoft Active Directory Federation Services (ADFS). Authentication against ADFS failed when using the mod_auth_mellon module. In addition, in Apache sessions, the limit for the number of elements was insufficient and multi-value variables were not supported. Also, the MellonCond parameter did not work when used together with the MellonSetEnv(NoPrefix) parameter. This update fixes the above described problems with ADFS interoperability. (BZ#1160636, BZ#1167796)
Story Points: ---
Clone Of:
: 1160803 (view as bug list) Environment:
Last Closed: 2015-07-22 05:45:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1075802, 1160803    

Description Jarek Polok 2014-11-05 09:52:49 UTC
Current lasso release (2.4.0 on 6.6 and 2.4.1(?) on upcoming 7.1) needs xml xsd:choices patches for Microsoft ADFS interoperability. Without these attempts to authenticate using mod_auth_mellon against our ADFS setup result in "Error processing authn response. Lasso error: [-427] When looking for an assertion we did not found it., referer [...]"

Patches from upstream lasso git:

http://repos.entrouvert.org/lasso.git/commit/?id=4ad4b673940ef72de1a62d7589cd0d86290086b1

http://repos.entrouvert.org/lasso.git/commit/?id=a27d1686b387a045607b5f0802001ea8863342cb

(Above patches are to be included in upcoming lasso 2.4.2 release.)

Patches apply cleanly to current lasso 2.4.0 and and fix 'assertion not found' problem.

Please consider including in next lasso update,

Thanks !

Jarek

Comment 2 Simo Sorce 2014-11-05 16:22:07 UTC
Thank you for reporting this issue.

Comment 9 errata-xmlrpc 2015-07-22 05:45:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1253.html